Waveform generator not sending any CC

I have set up a preset as shown in the video for modulating HX stomp. The reset command works perfectly but the generator doesnt appear to send any CC data either in the morningstar midi monitor nor down the midi cable. Any ideas?

Welcome! I’d guess it’s because all of your messages are set to Position = Both. Set msg 1 to posn 1, and set msg 2 to posn 2. If message 3 is supposed to trigger when you stop the waveform, set msg 3 to posn 2.

Come to that: do you need a stop waveform command at all, given that you’ve set it “once only”?

You may as well set all 3 messages to a Press action too. Different action for “disengage” not required here.

Finally, enable Toggle Mode on and Save. You’ll need to disconnect from editor to test it.

Hope that helps?!

Thanks for this. I need to read up on position states. Wasn’t aware of that. The idea is that the envelope will open as long as the pedal is pressed, then on release it will reset to the parameter in Message 3. I agree about the 2nd message but i copied this from the Morningstar walkthrough… It seemed to work in the example

5:54 all set to “both”

I still haven’t succeeded in sending any waveform data over midi. I’ve tried various midi channels, setting up as toggle, disconnecting from editor. Nothing seems to work. Has anybody had any luck with this?

Can you share your preset settings that is starting the Waveform generator? If you have it set to “follow midi clock”, midi clock needs to be running first in order for it to start.

I have tried with and without midi clock running. With perpetual or single wave cycle. Pretty much everythin. Is it possible my midi clock is broken?..

You can see in midi monitor the only thing being sent to physical midi out is the solitary cc reset command

You have set a press action to start the waveform generator(msg1) and then a release to stop it(msg2). is that expected? if you tap the button once ( press and release ), the waveform generator starts and stops so nothing is sent at all.

Also, just sharing this if you haven’t seen: https://morningstarengineering.atlassian.net/wiki/spaces/MMS/pages/211910676/Certain+Functions+Are+Not+Working

Yes i set it up exactly as in the Morningstar HX demo posted above. Hold pedal to send waveform, release to stop and reset. Seems simple enough but nothing is ever sent except the reset. Yes i have disconnected from editor and no difference.

Please tell me if I’m missing something obvious here. I totally understand what it is I’m trying to achieve and judging by the Morningstar vid, it should work perfectly

I just tested with your settings and it seems fine:

Based on your MIDI monitor screenshot, the device is still in editor mode because the switch press is sending SysEx messages to the editor. Do note that physically disconnecting the cable does not exit editor mode on the device. You’ll need to click on “Disconnect” in the editor.

Or, if you want to be connected to the editor while testing, in the editor settings, turn off Load Preset Data into Editor using Switch Press:

Hey Tom - I got it working!!!

Yes I understand about disconnecting the editor. My screenshot was a bit misleading.

The way i got this working was actually to turn off the “Load preset data into Editor using Switch Press” slider. Having this selected, for some reason doesn’t allow the waveform generator to work, even in standalone mode. Makes no sense to me but i can duplicate the problem…

Anyway I’m just happy it works now

Thanks Tom