Using the Relay Port For Clock AND Tap

So I have figured out how to use scrolling to have multiple tempo options to send out via Relay Clock Sync. What I can’t seem to figure out is how to get the Midi Clock Tap Menu to work with relay.

The goal would be to have my scroll lists and then use “Long Press” to get in to the tap menu so I can control all tempo related functions with a single preset footswitch. I can do this with MIDI Clock, but for some reason, the tap menu tempo doesn’t get sent to the relay port.

Am I missing something?

Thanks!

After changing your bpm in the tap menu, you will need to sync the relay port again to match the new bpm. Have you added a message to do that?

I have not! I will give that a shot and see what happens. Thanks!

Now that I look at it, I actually do. My MIDI Clock Scroll’s are all set to release, and at the end of the chain is a Sync Clock message on Press.

I put the Tap Menu on long press but the Clock Sync doesn’t seem to take effect when I am tapping in or when I exit the tap menu.

If you assign Press to clock sync and Release to clock scroll, clock will be synced before MIDI clock BPM is changed. This is because Press is always triggered before Release. You can refer to the action execution sequence for more information.

That makes total sense… I think that since it’s a pretty quick press and release, there seems to be no issue with it syncing to the current scroll selection every time I press and release

The best way would be to add a Utility message to set messages to scroll by 2 messages at a time. Then add a relay clock sync message to each of your MIDI clock BPM messages. That way you will change BPM and sync with every press. Made an example for you here (scrolls between 90 and 120 bpm but you can of course add more):

I’m not actually having any issues with this part… I placed the sync at the end of all bpm messages and it has no issues with syncing after every press and release. What I was hoping to do was also have a way to have the Tap Menu worked into this preset as well (I tried entering the tap menu with a long press) but the bpm sync doesn’t seem to work with the Tap Menu