Trouble with MC8 + Disaster Area midi box 4

Greetings! I’m having an issue which I’m fairly certain is something simple I’m missing, but at the moment I’m stumped.

I just received my brand new MC8. My MIDI setup prior to introducing the MC8 is:

DAW(reaper) as source of MIDI messages → scarlett 2x4 interface, 5-pin out → 5-pin in, Disaster Area midi box 4 → TRS to a few chase bliss pedals, AND → 5-pin out to Hologram Microcosm. All this works great.

When I received my MC8, I configured a simple test preset to send the bypass CC to the Microcosm. I then unplugged the 5-pin cable from my audio interface and plugged that into the Midi out of the MC8. When I press the switch the engage the new preset, the microcosm doesn’t respond.

I’ve tried a bit of troubleshooting so far. I verified that I had the correct channel, CC # and values in the preset. I verified via the morningstar web editor’s midi monitor that the preset was sending the correct CC # and value. I re-tested via my DAW and that’s still working. I also tried a similar test with two other pedals in the chain(chase bliss mood and chase bliss blooper, FWIW), and they, too, are unresponsive. I have not tried sending via an omniport yet, because I’d prefer to keep my current setup as-is and expand to new pedals in the future using the omniports. 5-pin to midi box is how I’d like to connect the MC8, and from what I understand, that should be doable.

Short of an actual hardware problem with the MC8, I feel like I’m missing something simple here. Everything downstream from my midi source is identical. The only difference is MC8 sending midi vs DAW/interface.

Is there a configuration in the MC8 that I’m missing that’s causing the MC8 to not send via 5-pin out? Some sort of compatibility issue with the DA midi box?

Any help would be greatly appreciated.


I can confirm that the Midi Box 4 box works fine with the MC8. I’ve used mine with my Chase Bliss Brothers, Boss OD-200, and Jackson Audio Bloom. The midi box 4 is powered by it’s own 9v DC power, so I don’t think the type of 5 pin midi cable would be an issue. And Midi Thru On/Off in the MC8 shouldn’t be an issue since you are sending the command from the MC8 itself.
If you haven’t already, be sure the USB is unplugged and you are fully out of edit mode when testing. Maybe send some screenshots of the preset programming in the MC8 for others to double check it.

Thanks for the reply! Everything you say makes sense - I did wonder about being in edit mode, so I unplugged and re-powered to be sure. Unfortunately, same result. Great idea on the screenshots.


Made a quick video showing current setup(working), MC8 setup issue, and the preset definition for those interested in helping to troubleshoot.


I did some further troubleshooting. I connected one of my pedals to an omniport on the MC8 and the pedal behaved as expected which verified my preset definition. After that I swapped the 5-pin cable going from MC8 to midi box with the one from midi box to microcosm. This worked. And oddly enough the microcosm preset worked as well. So I have a working system now, but I didn’t exactly determine a root cause. I can’t purely point to the cable, since that same cable works fine between the midi box and the microcosm just not between the MC8 and the midi box. So there are a few possibilities I can imagine. Perhaps the interface between that cable and the MC8 isn’t great and maybe the midibox jack is more forgiving than the MC8 jack(or same for the midi box input jack). The “bad” cable is 10 ft, and the working cable is 3 ft, so perhaps the signal from the MC8 isn’t strong enough to make the 10ft distance but is ok with 3ft or, probably more likely, there’s something wrong with the cable internally and it is somehow attenuating the signal enough to affect the MC8’s transmission but not the midi box’s.

In any case, unless there’s someone more knowledgeable than me that has more input, I’ll call this good and just continue to mind the cables if issues arise.

Troubleshooting for the win. Nice board by the way.

Some midi cables can have little quirks. For example, I’ve learn from experience that the One Control Midi Hammer cables are not capable of carrying phantom power to things like midi thru boxes. All your devices involved appear to be running off their own power, so something like that wouldn’t be an issue.

I wouldn’t think that short of cable lengths would make a difference either way. One might have a minor short or other difference with the pins. Only a cable tester would answer that. I have good luck and no problems using the RockBoard FlaX midi cables in all situations.

Glad it’s working. In the video it sounds like you got a decent grasp of the workings of midi to come up with some ingenious ways to put the MC8 to work. Browsing the forums and tutorials can give you a few good ideas too. Have fun!

1 Like

From experience, if the problem is intermittent, 99% of the time it is a bad cable. If the issue re-occurs, try using a different cable and see if it resolves it.

1 Like

I use a 20’ cheap midi cable to go from my MC3 back to my mixer, including a TRS/midi adapter, and 2 couplers. I’d doubt the cable length is an issue, seems like the MCs put out a strong signal and/or midi overall is pretty tolerant of some signal loss.

@barneco @jmay214
I am trying to make reaper change presets on my MC6. There is no problem switching banks already, but there is a problem switching presets. MIDI dictionary says I should send CC 10 message with value 1 to turn the preset A on. But CC 10 is somehow reserved in reaper for the “Pan Position MSB” and when I use it, the MC6 just gets freezed until I reboot it. Here is the MIDI monitor log when I use the СС10 in reaper:

16:50:00.962 To X18/XR18 Control 3 Pan (coarse) 1
16:50:00.964 To X18/XR18 Control 3 Pan (coarse) 1
16:50:00.964 To X18/XR18 Control 3 Pan (coarse) 1
16:50:00.964 To X18/XR18 Control 3 Pan (coarse) 1
16:50:00.966 To X18/XR18 Control 3 Pan (coarse) 1

and it does not stop.

What should I do to make it work correctly?

It sounds like a midi command feedback loop. The Midi Out of MC6 connected to Midi In of Computer. And Midi Out of Computer connected to Midi In of MC6. The command gets sent and runs through both devices over and over.
The Solution is to turn Midi Thru Off on the computer or on the MC6 (I believe pressing buttons A + F performs this on MC6)

I tried to turn MIDI thru on and off, it doesn’t matter. I think MIDI CC 10 message acts like this in reaper? maybe it’s possible to reassign preset A in MC6 to any other free MIDI CC message number from reaper?

What does your Preset A look like? So when you send a CC#10 to the MC6, it sends a CC#3 message back to the Reaper?

MC6 does not send anything to reaper. 3 in log is a midi channel to send messages from reaper to MC6.

FWIW, I tried using the omniport on my MC6 to a Disaster Area Midi 1-4 box using a standard TRS to 5-pin cable. Most things works but a few didn’t for no reason. Switched to using the MC6 5-pin and a standard midi cable and now everything works.

I found out the hard way that the DA midi box 4 does not pass midi input from the trs ports to the DIN output. The Meris Midi I/O will do that, presumably since their pedals are designed to send midi info as well as receive it.

My issue was with going from the MC6 omniport (TRS) to the DA 5-pin. Didn’t work for some devices downstream, but works fine with 5-pin to 5-pin.

Oh, I totally missed where you said that. Interesting!

Ok it looks like it is possible to use CC numbers reserved in reaper for other things. So when I send CC10 it really turns the Preset A and so on, but it sends the same message 7-8 times, I don’t know why. If there is a loop then how can I troubleshoot it? I turned the MIDI thru on the MC6 off, and on the MIDI monitor of the MC6 there is no other info except that is outgoing to my other devices which are not connected to the computer at all. I made some screenshots showing what is sending from reaper and what shows the MC’s MIDI monitor. Id does not show messages from MIDI in, only what it sends from MIDI OUT.

Here are sreenshots of preset A and C which I monitored on earlier screenshots.

@teabandito You’re posting in a thread concerning problems with a disaster area midi box, so do you have one of those in your chain? If so earlier posts indicate unexpected behaviour unless using midi 5 pin din cables.

Can you write out your midi chain from start to end including the connectors (usb, din, etc) used for each?

All of your devices are on unique midi channels?

Your preset C screenshot has message has toggle position as ‘1’. I doubt it will fix the problem but I think that should be set to ‘Both’ not ‘1’ because it doesn’t look like you’re using toggle? Unless you’re setting toggle when entering the bank, I guess.

Come to that, have you got any midi triggering when you enter this bank on the MC that could be causing the issue?