Trouble with expression pedal(s)

i have a Mission XP1-L6 expression pedal that stopped working with my Morningstar MC6 controller. The pedal would start at zero, and when it got half-way down it immediately jumped to 100%. I thought the problem was the pedal, so I purchased a Dunlop volume(x) mini pedal and that pedal has a similar behavior. When I try to calibrate, the MC6 asks for the heel position and the toe position, and both show 0%.

In my setup, I have the MC6 connected to a Helix Stomp, which worked with my Mission Xp1-L6 no problem until one day it just stopped working. Anyone have any insights about what’s going on? It doesn’t appear to have anything to do with the helix. The pedals just no longer want to calibrate. I’ve tried the sensitivity setting on low, med, and high and the same thing happens.

Thank you!

Have you tried a different TRS cable just to check if it isn’t a faulty cable?

For Line6-style expression pedals, those have never been compatible with our MIDI controllers. Those expression pedals use a rheostat style wiring, while most other expression pedals (that are compatible with our MCs as well) use a voltage-divider style wiring.

yes, I’ve tried a different TRS cable but that doesn’t fix it. Both of the pedals I’m trying are said to be compatible with MorningStar MC6 midi controller. And… the Mission SP1-L6 pedal that I was using worked just fine for several months before everything just stopped.

Just to clarify- I’m using the pedal to control midi input to the Helix stomp. The pedal was setup on cc12 so that it could be applied as an effect to volume, drive, etc. depending upon the preset being used. it all worked just fine for several months before just stopping.

So… the expression pedal is connected to the Morningstar M6, and the Morningstar M6 sends MIDI signals to the stomp. None of the settings on the stomp were changed at all. In fact, none of the settings on the Morningstar m6 were changed either. It just stopped working.

I’m sorry to point out the obvious, but did you double check the omniport settings or try a different omniport?

And if you’ve done a firmware upgrade recently, worth making your settings again, saving and restarting. That sometimes helps!

1 Like

yes, i’ve done that using both pedals. I calibrate them again, and all they will do is set at 0% 0r 100% but not in between.

I did do a firmware update awhile back. That might have been the root cause of my problem-don’t really know.

1 Like

shot in the dark cause idk why it would stop working randomly but I think the Dunlop has a switch inside you need to flip to be compatible.

It might be related. We’re working on the v3.12 beta release for the MC6MK2 to give the user more options to set up the exp to resolve this.

1 Like

Argh… when will the v3.12 release be available??

We’ll compile an updated firmware for MC6 v3.11 later today.

Fixed firmware here: Release Firmware v3.11.2 · Morningstar-Engineering/MC6-MKII-MIDI-Controller · GitHub

If you do give it a try, let me know if you continue to face any issues, thanks.

1 Like

Thanks James - but no, it didn’t work. The toggle on my Dunlop pedal is set to exp. I’ve uploaded the hex file (the one for ‘no keyboard’). When I try to calibrate, on heel down the number that is showing in the window is 1. When I press on the pedal, the number field kinda goes fuzzy- i don’t see it moving up or down, until I get to the toe down, at which point the number in the window goes back to 1. I have the midi connections connected to a helix stomp, and the expression pedal setting in Morning star and helix both to midi channel 1, and cc12. When I move the pedal up or down nothing happens. It used to awhile back but it just stopped. I think i’m concluding that the MK6 physically is somehow broken. What do you think?

I don’t think its likely that the omniport is faulty but let’s troubleshoot… Have you tried a different omniport? Also, can you confirm that your Dunlop Exp setting is to as such?

Yes, I’ve tried both omniports. I’ve checked the cable and tried a different one and it didn’t make a difference. The setting of the Dunlop exp are as you’ve described. I also have a separate mission sp1-LG pedal and it behaves the same as the Dunlop. When I updated the Morningstar firmware, I used the version without the keyboard.

I had this issue a couple weeks ago after one of the firmware updates.

My expression pedal (Dunlop x) suddenly stopped working.

I gave it a firmware update again, as another patch dropped soon after. After this patch it was fixed.

I think I went with the standard firmware, maybe the No-keyboard version still has this bug?

I tried the no-keyboard firmware (though it shouldnt make a difference) and it works fine. Can you try in the following order:

  1. Verify again that the omniports are set to Exp, and then save it and restart the controller
  2. Reset the exp sensitivity to medium or high
  3. Re-calibrate the exp
1 Like

James - nope. Omniports are fine, recalibrated, high sensitivity - no change