Trouble sending PC msg to Neuro Hub

Has anyone cracked the code on how to send PC messages from the MC6 MKll to Source Audio’s Neuro Hub to control pedals hooked up to the hub (ie: KingMaker and Spectrum Filter)?

I already control 2 neuro hubs without any problem, with USB or DIN.
Check that your hub (and pedals, but not mandatory) is on the same channel as the one you are sending the PCs and CCs.

Wow. That’s awesome. I’m sort of new to Midi and the MorningStar MC6 MKll.
If you don’t mind, how exactly do I go about setting the midi channels from the
MC6 to match the neuro hub? I’ve checked a new hubs manual and it’s not quite clear? Also, is each pedal better off being on its own Midi channel?

Thanks in advance!

Just send PC and CCs on the same channel number as the one you choose for neuro hub using the Neuro Desktop app.

No for SA pedals connected to the hub use same channel as the hub, it is simpler when beginning.

Excellent! Sounds simpler than I was thinking of.

I appreciate ya’!

so do i need the neurohub between the MC8 and the Source Audio pedals? won’t the MC8 communicate directly?

It appears that Neuro Hub is the only way to communicate with the SA pedals. I found that the trick was getting the MC8 to communicate with the Hub. I didn’t have much success though I’ve heard others say they found a way.
Good Luck~

which SA pedals do you have? my understanding is that the Nemesis, the Collider, and the Ventris . . . none of them need the neurohub. but they DO require 5 pin midi connection. no usb midi.

The Neuro Hub is the only way to communicate with the One Series pedals from SA (pedals with one footswitch - kingmaker, LA Lady, etc) but any of the dual footswitch ones (Collider, Nemesis, Ventris) can connect directly via MIDI cable.

So here is what I learned from SA in regards to connecting Morningstar MIDI devices to the Neuro Hub - the Hub is not as dynamic in the Neuro editor as other pedals directly connected to the editor. What this means is that when you set up a scene on the Hub, you will not see it change in real time in the editor. But! It is changing. So setting up a specific scene on Scene 001, will actually receive that PC number - you just won’t be able to see it change anywhere.

It was really maddening for me, because I thought it was broken, but after a bunch of back and forth with SA including me sending in a video of my rig and issue - they told me that the Neuro Hub is on old firmware, and will not display program (scene) changes in real time on the Hub, but the scenes are changing!

It takes a little bit to understand the number correspondence, but it does work.

I use SA C4, Hub and MC6. I don’t use the Hub to store scenes, I just send CC values to the C4 from the MC6 to engage preset sounds and/or change values. For me (especially with only one SA pedal) saving scenes on the Hub is an extra programming step: and AFAIK some of the more recent pedals (e.g. Ultrawave) have so many parameters that the Hub can’t store ALL of them.

My setup is: C4 on MIDI channel 1, MC6 on 2, Hub on 3.

I defined a name for my C4 in the Morningstar editor (and of course, this principle expands as you add more devices):
image

I added a couple of CC entries in MS User Library:
image

Finally my presets to engage sounds on the C4 look like this:


…in this example, the sound stored against ‘010’ on the C4 is engaged (the 9 versus 10 difference is because SA count from 001 and Morningstar count from 000 - it’s a MIDI thing :-))

Of course, if you want to engage many SA pedals from one preset on MC6 without using scenes on the Hub, you would add more messages within a preset e.g. CC Number 104, CC Value whatever; MIDI Channel e.g. 5 (or whatever channel the pedal is on).