Trouble getting MC8 to take Aux Switch programming on desktop editor

Hello Brilliant People,
Here is a brain buster. I have been trying to get my aux switch set up with my MC8. 3 button switch, wired correctly by simple switch (yes, i checked it with a meter). I am able to program each preset button, and save them, but the MC8 only responds to T, not U or V. Any ideas? I just want it to bank up on T, Band down on U and jump to bank 1 on V. It seems like it does not take the programing at the MC8. Please forgive me as i am new to morningstar, but, i have successfully programmed bank 1 full of cc messages that work, so, i can’t understand why i can’t get this going. Im sure i am probably missing something.

Have you made sure you’re connected to the right Omniport (I believe EXP port 2 for TUV), and that it’s set for Aux Switch?

Yes. I have done that. It is set for aux switch.

How do you have the aux switch wired up? Can you share a picture of the wiring?

I’m assuming it is connected to Omniport 2 (to control T, U and V). If you can get T to work, that means the controller is reading the Tip being shorted to ground. Preset U engages when the Ring is shorted to ground, and V is when Tip + Ring is shorted to ground.

If you turn on this setting in the Editor Settings tab, does pressing the switches load the presets in the editor?


Here is the switch internals. Sw1 is left, 3 middle and sw2 on right, that is if the jack is lower left.

I compared to the wiring diagram in MC8 manual and it looks correct.

Yes, but only for T.

Are you using a TRS cable?

Thanks, yup the wiring looks correct.

This might be the most obvious explanation. Although if a TS cable is used, the ring is always shorted to ground which should “hang” the controller because the controller is reading as a switch being pressed. Can you confirm though, if a TRS cable is used?

Yep. TRS for sure. Ive checked it with a meter several times. Made it myself. Sp550s squareplugs, belden mic cable.

If you use another omniport setting, like Fixed Sw Custom with a setting like below, are you able to get the functions to trigger? How about using a different omniport?

James,
Im travelling for the holiday. I will try those settings on monday when i return. I tried the fixed custom last week, and down (left or sw1) worked, up (sw2 or right) also worked for a bit. Then only the left worked when i tried to use aux setting, and upon returning to fixed custom, only the left worked. It seems like maybe a jack isnt making contact as someone stated earlier, but, i have put a bare trs plug in the switch jack and metered from plug contact to swtch lug and all 3 were good for what its worth.

No worries - when you have a chance, do let me know if it works if you use a different Omniport.

Have a good holiday!

Ok, i used a different port, for example omni 4. I set it up as fixed sw custom just as you showed with L as bank down, M as bank up, and N as toggle.
Behavior is as follows:
Pressing L (left button) banks down
Pressing M (right button)does nothing
Pressing N (center button) also banks down

How should i proceed?

how about for the other 2 omniports? All the omniports are independent, so if your aux switch can’t work with all the ports then i’d suggest checking the wiring or cable again.

We have a switch test function but i’ve not incorporated the function to the omniport ports yet. I can do an update in the firmware so you can check exactly what is being shorted to ground (Tip or ring or both) when you use the aux switch. Can you drop us an email regarding that?

Well, you were right. 1 more round of testing with meter. Cable tested good still. Switch tested good. Stuck a different trs in switch and tested it. It was good. Tried in controller again and only down worked. Pulled exp cable off my deja vibe and used it…all aux functions worked. Remade cable with a different piece of xlr and its good now. Cable must have an intermittent short in it somewhere. Threw it away. Thanks.

Resolved.

1 Like

Thanks for the update - glad to know that you managed to find out the issue. Faulty cables happen more often that one might expect - and if a problem is intermittent, its almost usually the cable :+1: