"Transmission Error!" message on MC8 with ML10X and WidiJack

I have an MC8 [3.10.2] and an ML10X [1.1.2]. I’m trying to set them up using a WIDI Jack on each device. When I send a “Select Preset” message using the “Morningstar ML10X” message type, the preset loads on the ML10X as expected, but I get a momentary “Transmission Error!” message on the MC8 screen.

I suspect this is some kind of MIDI loop issue because if I disconnect the MIDI In cable on the MC8, the error message no longer appears. Likewise, if I disconnect the MIDI Thru cable on the ML10X, no error. Seems like a simple solution, but my challenge is that the Widi Jack is powered via the MIDI Thru cable on the ML10X and I’d like to keep MIDI in/out connected to the MC8.

I have MIDI Thru turned off on the MC8.

The ML10X MIDI Thru port is purely a THRU port, so any incoming MIDI messages going into the ML10X MIDI IN will appear in the MIDI THRU port as well.

Unfortunately, that means that if you are using the WIDI Jack, you’ll need to only connect it to the ML10X MIDI IN port, while powering the WIDI Jack via USB C.

You can try raising a request to CME for an update for a “MIDI Thru” setting, so that incoming MIDI messages from these MIDI THRU ports can be ignored by the WIDI Jack, while still being able to be powered by them.

Understood, thanks for the quick reply!

1 Like

I reached out to CME, who responded quickly. They do not have specific firmware to disable/ignore data on the WIDI Jack Input, but did suggest “cutting the data wire” on the cable. Using fine-tip needle nose pliers, I carefully removed pin 5 from the DIN5-to-TRS adapter and this worked. The WIDI Jack is now powered by the ML10X, but does not receive any MIDI data from the Thru jack. Cheap and easy solution! For those wanting to try this, Pin 5 connects to the TRS ring–I used a multimeter to verify the correct pin before removing it.