Throw the MC6 and my Walrus pedal out the window...or not? read this

I really didn’t need much to lose my nerve and throw the MC6 and my Walrus Audio M1 pedal out the window.

Nothing worked. I was seriously starting to lose my patience. In addition, the incessant bugs (for example all the parameters of the midi dictionary that I had set as favorites which disappear, the crashes of the editor which restarts my mc6 but does not recognize it (connection failed) do not help things…
version

I really tried everything to configurate
Bank 2 to do this:

  • Pressing the A button turns the chorus on, pressing it again turns it off
  • Pressing the B button turns the Phaser on, pressing it again turns it off
  • Pressing the C button turns the Tremolo on, pressing it again turns it off

etc etc etc for the D, E and F buttons.

I have tried really everything, without any kind of success

  • PC# message only - activate the effect but impossible to turn it off with another PC# (seems logical)

  • CC# to activate and deactivate the effect, it worked, but switching from one preset to another, it was ever the same preset that was active so the programmed presets were not activated.

  • PC# messages in position 1, 2, shift or both. Some positions worked, others didn’t. (Besides, I haven’t found how to adjust the position for PC# , where is it explained?)

  • CC# in position 1 and 2. It worked with completely random results, which also depended on the position that I had programmed in the PC message above; which you can imagine, gave me a hell of a mess.

  • Midi send delay time as James advised
    :point_down:t2:

nothing worked, NOTHING.

Here, at home, in France, it is 1:10 a.m.
I am writing this message because I ended up finding where the problem comes from.

No, this time, despite the fact that I am a real newbie in midi, it was not my fault but indeed a bug.

Moreover, by resolving this problem, dear morningstar Staff, you will solve my problem and avoid many problems for other users.

I will explain to you what happened; I can explain the “why”, but not “how” on the IT level, it is possible, but it is a problem that needs to be resolved.

As described above I had tried everything, the CC# that I needed in my case, to activate or deactivate the presets, being #31 (value 0=Off, value 127=On)
:point_down:t2:

But as described above, nothing worked.

I really wanted to throw everything out the window because even if I’m not a midi pro, it should respond to a certain logic, and not being completely stupid and idiotic, it had to be within my reach.

But nothing worked.

So, just to move forward a little, I reprogrammed the favorites (3 pedals) from my midi dictionary which for some unknown reason have disappeared, what is happening very often since updating to this version.

Then I reprogrammed my presets using the midi dictionary instead of entering each preset by hand, CC#31, value 0, value 127 etc etc etc for each preset.

That’s when i saw the description of the effect under the midi dictionary panel.
:point_down:t2:

And since then, everything has worked perfectly.
Bank 2 is configured so that:

  • Pressing the A button turns the chorus on, pressing it again turns it off
  • Pressing the B button turns the Phaser on, pressing it again turns it off
  • Pressing the C button turns the Tremolo on, pressing it again turns it off

etc etc etc for the D, E and F buttons.

Since I selected the CC# with the midi dictionary it works;
When typing them by hand nothing worked.

Do you realize the mess? This problem absolutely needs to be resolved. Thank you to the morningstar staff for doing what is necessary.

For information: the description of the walrus Audio M1 pedal is not on the right place

the reason ist explained here: :point_down:t2:

Description of walrus M1 in the midi dictionnary

I really hope that someone reading this topic will really do what is necessary.
thank you.

The favourites data is stored in the browser local storage, so just check that you are not clearing the cache, or have any plugin that is clearing the cache when you close the browser.

This is the same for the preset message description.

If you are using the desktop editor, and you downloaded an updated version, the data is not transferred over.

image
As per what we show in the editor when you enabled the feature, the feature is experimental, and we recommend you backup the data yourself.

The MIDI dictionary descriptions are unrelated to what MIDI messages are being sent. It is just a utility to show you the function name based on the MIDI dictionary and your MIDI channel name. It is currently matched via an algorithm, so I think what we happening is Walrus M1 (as per your MIDI Channel name) and Walrus Audio M1 (as per in the MIDI dictionary) are not getting matched. We can look into how to further improve this.

But, as mentioned, this is unrelated to how your MIDI devices respond or what MIDI messages the controller sends out. If the MIDI devices are not responding as per how you want it, then just check your MIDI message and the MIDI monitor to see what is being sent.

ok i will look at the midi chanel name

Ok, I’ll see about renaming Walrus M1 to Walrus Audio M1.
But you must admit that this problem is still quite strange.
It was just pure chance that I managed to find it.
Very often it’s like that. We have a problem that we spend days on, and the solution is in front of you , we just still have to think about it :woozy_face:.

For ergonomic reasons it would still be good to fill in the description of the Walrus Audio M1, and especially at the right place (that’s not the case at this moment).
If we compare to the other effects, the description is clearly out of place.
look:

Boss OD-200
:point_down:t2: :point_down:t2: :point_down:t2:

Source Audio Ventris
:point_down:t2: :point_down:t2: :point_down:t2:

Walrus Audio M1
:point_down:t2: :point_down:t2: :point_down:t2:

It’s the missing description that implies it’s not in the right place. Maybe that’s why it’s a mess? I don’t know, I guess, I’m not a computer technician.