Strymon Conduit - isolate ground issue?

I have midi clock noise in my signal when sending clock to a Meris Mercury7 and Strymon El Cap V2 via trs with MC8 omniports. If the trs midi cable is unplugged from either pedal, the noise stops.

I’ve tried clipping the ground on one of the trs cables, but it didn’t stop the noise. I’ve used a 5pin to trs cable coming from thru on a previous pedal, but I’ve made some pedal changes and what I have now isn’t sending the right data with the 5pin to trs (it is sending to other pedals in the midi chain, just not to through trs).

Would a Conduit give me the isolation I’m looking for? Any problems adding in a Meris pedal to it? I’m not looking to connect to a computer or anything, just control from MC8.

The noise issue has been fixed. I never changed the omniports from Midi standard as everything “worked” with the default settings. I went in and changed the omniports to the El Cap and Mercury7 to be active on tip (how they both receive) and the noise was eliminated. Both ports had to be changed. Just changing one or the other didn’t fix the noise.

Multiple Strymon pedals seem to be fine running the default omniport setting though.