Specular Tempus to MC8 through expression port

Trying to connect my Specular Tempus to the MC8 through the expression port although that does not seem to be working. I have a 1/4 inch TRS to midi cable and I’ve tried all the ports and nothing is working. When I go through the HX Stomp to the Specular Tempus that works so the midi port on the Tempus seems ok. Am I using the right cable? Any suggestions? Thank you!

Is your Omniport set to MIDI OUT in the Controller settings? Also check the internal jumpers (backplate needs to be removed) and see if the jumpers are set correctly. If you bought the unit new, the default setting should be correct. More info here: https://morningstarengineering.atlassian.net/wiki/spaces/MMS/pages/171802626/MC8+v3.7#Connecting-TRS-MIDI-Devices

OP, did you ever fix your issue with this? I just got an MC8 and I’m trying to use the Omni ports to control my two Specular Tempi. The ports are set to midi out and they’re trs to 5 pin midi. I’ve used a multimeter to check the cables and they’re functioning as they should be, but the Specular Tempi aren’t responding to midi messages.

(I’ve double checked the midi channels and everything lines up and should work. I’m also using an omniport to control my Iridium and it works as it should)

Are the 5pin to TRS cables you used specified as “Type A”? There are a lot of variations out there - but the MIDI standard is Type A.

Thanks for the reply James! I’m using a Squareplug SP550-S for the TRS side, a Switchcraft 05DL5MX for the midi connector, and Mogami W2697 cable to connect the two. I tried configuring the omniports to send midi via ring in the desktop editor and it didn’t work. I tried opening up the back of the MC8 and configured the omniports to send midi via the ring that way and it works perfectly now! Thanks for your quick replies with this.

No worries, glad to know that it is working.

Just FYI, seems like your cable is a Type B connection, which means that it needs a Type B setting to work with 5PIN MIDI ports. There isn’t a Type B setting for the Omniports yet but it has been added in firmware v3.9, so that means in v3.9, there isn’t a need to move the jumpers anymore - just select MIDI OUT - Type B

I can’t wait for v3.9!