[Solved] Web editor on Big Sur

Hi, I am having problems using the web editor with MacOS Big Sur. It can see the device but doesn’t connect when I select it. Has anyone else noticed this?

There seems to be lots of strange issues with USB on Big Sur as I am also getting a lot of drop outs connecting to my Helix.

The other strange thing I have noticed is that if I connect via a hub the MC6 appears twice in the editor with different device names.

Thanks for reporting this.

Can you go to https://www.midimonitor.com in Chrome, click on “Devices” and then share a screenshot here, or email it to us? That will help us to troubleshoot the issue.

I’m running Big Sur as well on a 2019 MBP without any issues. We had one user who faced similar issues and the problem turned out to be the Satechi USB Hub.

This is with MC6 connected directly to a USB-C port on the MBP

any more thoughts on this one?

Yes, apologies for missing this. Not sure why the MC6 device ID is labelled as HELIX. I’ll push an update to the web editor today and hopefully that solves the issue.

Can you test your connection in the staging web editor and see if the issue is solved? If so, I’ll push the fix to the main web editor

https://editor-mkii-staging.morningstar.io/

Yes that appears to be working. Thank you!

Thanks for the update. I’ve pushed the changes to the main web editor.

There’s some issue with saving the preset. I had to rollback the changes in the main web editor first. Will need a day or two to look into it