[Solved] After upgrading MC6mkII firmware from 3.6.2 to 3.7.x the MC6 is no more recognized by an USB host

Hello,

I upgraded without problems but…

I am using MC6 with its USB connected to an IConnectivity Host Device, and it has always been working ok with previous firmwares.
But here, the IConnectivity USB Host no more recognizes it.
This could happen when a device is not USB compliant.

If it could help solve the problem, with my Elektron models:Cycles and Samples, when I program their USB to manage MIDI and AUDIO, I can’t pilot them with my IConnectivity MIOXM or IConnect Midi 4+, but if I remove the audio part from their USB (a setting feature) everything is Ok.

As you have changed something on the device USB Id, it could be related.
I hope you will solve this issue because I had to revert to 3.6.2 without the very interesting features of 3.7.x.
Best

Thanks for the feedback. Changing the USB ID will not affect whether the device is USB compliant or not. Does the issue resolve when you revert back to v3.6.2?

If you are using a mac, can you provide a screenshot of the USB device? Its under About This Mac >> System Report >> USB (Under hardware) >> Morningstar xxx

image

Hi,
Thank you for fast answer.
Yes, as said, it solved when reverting to 3.6.2.
I am on W10 when using the editor but when playing I have no computer connected to MC6, only the IConnectivity Midi 4+.
If you don’t know IConnectivity midi devices, they are used to manage midi networks, and audio path, I suppressed kms of midi cable and tons of midi solution like boxes using a couple of them, and on stage they integrate the very usefull RTP/Network-MIDI protocol. Very pro equipments.

Best

I think what I can do is compile a firmware with the previous vendor ID for you, and then you can give it a go with your other hardware. Do drop us an email regarding this. Thanks!

Hello James,

Send it to me, I will try, thank you.

Best

Christian

Hi James,

I found the issue, no need for a specific version.
All my previous IConnectivity settings concerning MC6, related to the previous ID, are no more valid.
I have to re-enter all the routings, all the filters, all the mappings for MC6.
Some hours to upgrade everything to use this ‘new MC6 USB device’ with a new ID…
People using same kind of routing equipments should be warned about this consequence when upgrading the firmware to v 3.7.x from 3.6.x

EDIT : finally I had just to remap the new ID to the old one and recovered the settings without having to re-enter them. :wink:

1 Like

Thanks for the update! Glad that it is fixed.

We’ll include that note in our release notes.

2 Likes

Thanks, please do have a look on my issues with RT Clock I logged in the Github issues thread.
Best.