Short press and long press on the same button

Hey everyone, just got my MC8 and I’m trying to set the same button for a short press and a long press. However, whenever I try the long press, it also sends the signal for the short press. Should I be setting this up in a specific way to avoid that? Thanks!

Take a look at the Help menu of the editor in the “Action Glossary”.

A Long Press action will also execute a Press action. Hence, if you want to execute 2 different actions with a Press and Long Press message, you should use a Release and Long Press message instead.

Logically, the only way for a Long Press action to prevent a Short Press would be for the Short Press to wait for the long press wait time … which isn’t great.

1 Like

Thanks for the reply. I actually did read that part, but I’m not sure what I’m supposed to assign the release to. What I’m trying to accomplish is have a short press act as A regular footswitch on the Quad Cortex which is a midi message, and then use a long press to switch to Scene mode. Both of those actions are listed in the midi library. by the way, it was absolutely brilliant of them to include that in the editor. It saves so much time!

Think of “short press” as Release, ie change anything previously programmed for Press to Release. If that doesn’t work, go ahead and post a screenshot of your settings so we can take a look.

OK, so I obviously don’t know what I’m doing. I am attaching a photo of preset A in my Quad Cortex bank. What I am trying to do is have switch A do two things. First, I want it to just register a button press which will trigger an action on the Quad Cortex. Secondly, with the same button I was hoping to use a long press to activate the preset mode on the Quad Cortex. (Alternatively, button B and C would activate the scene and stomp modes respectively.)
What I want is to be able to activate the preset mode (or scene or stomp mode) WITHOUT having it trigger the regular button press as well. I hope that makes sense. When I switched from long press to release, it still activated the regular button press. Maybe there’s a different type of command that I can use to achieve the same thing. thanks for your help.

in your screenshot, change press to Release

and Long press release to just long press

1 Like

Well, that did the trick! Thank you so much for your help with this. Now it’s behaving exactly as I wanted. I’m so glad I found you guys, and Since I’m really new to MIDI, I’ll try not to be too much of a pain.