[Resolved] MC8 not getting clock from Digitakt

I’m stumped, but also assume I’m missing something silly and obvious…

Digitakt and Digitone are synched and work fine together. But…clock isn’t getting to my MC8 to then synch up w/ guitar. Or if it is, it’s not making it to the rest of my pedalboard.

Separate by relevant - tap tempo on the MC8 does make it to my pedals, so I know that signal is going out.

I have:
Digitakt midi out > Digitone midi in > digitone midi out > midi in on MC8 > midi out on MC8 to board.

  • Clock send and transport send are both turned on on the digitakt.
  • same on digitone (and receive is on too, obviously)
  • On the MC8 I have “midi thru“ and “ignore midi clock” both on, which I believe is correct.

But…

When I change bpm on the digitakt the digitone responds no prob…but the MC8 and rest of my boAre does nothing. Would love help!

Ignore midi clock should be off on the MC6.

Appreciate the follow up. My understanding is that ignore midi clock is supposed to be ON. I found a post from James saying that when ON this means clock will be passed from an external source thru the MC8 without any internal processing (ie “ignored”). This is intended to minimize chances of the clock could go out of synch as the MC8 processes other messages.

In any case I did try what you suggested and still nothing. This is very strange! Thanks again though.

If Ignore MIDI Clock is turned on then any incoming MIDI clock messages are ignored i.e. not processed and not passed thru. If you want to pass incoming MIDI clock messages from the MC8 MIDI IN to the MC8 MIDI OUT, you’ll need to turn Ignore MIDI Clock off, and then enable MIDI Thru.

If the MC8 is receiving MIDI Clock and passing it through, the incoming MIDI Clock BPM should be displayed on the screen, but not blinking.

Thank you for clarifying! I misunderstood that. I did try that before but must have done something else wrong because it does work now.

Hey, tried what you suggested again and it does work now. Thank you for the help.

Happy to help. Enjoy!