[Resolved] Editor no longer works in Linux - MC8, MC6 Pro, and MC3

I really appreciated that I was able to use the Editor for my MC8 under Linux. Fast forward after a time of using a modeler and have moved back to discrete pedal boards, plus picking up an MC6 Pro and an MC3 and now none of them can be edited under Linux.
Under Linux I see:


Under a Mac I see:

Consequently the Editor does not work under Linux as it once did as all connection attempts fail.

We’ve never officially supported Linux but let me check what changed.

Meanwhile, can you try the Serial Port connection and let me know if it works for you in Linux?

Ttrying to connect to the serial port did not work. However the update to the editor that happened today did allow me to connect to the MC6 Pro (didn’t try the MC8 or MC3 yet). I didn’t try to edit/save anything yet, but it’s clearly a step in the right direction. WIll have some time soon to work with it a bit.
Thank you!
Chris

Did some follow-up testing tonight.
Although what’s displayed in the browser window is the same the page can now connect to and edit the MC3, 6 Pro, and 8 using Chrome on Linux.
That last update clearly fixed it.
Thank you!
Chris

Thanks for the update! Glad to know that it is working again.

This is still not working for me, even after updating firmware to 3.12.6

Which linux distribution are you running and which version of google-chrome ?

Gentoo with Google Chrome (Official Build) versions 123.0.6312.22 and 122.0.6261.111.
All 3 work fine - MC8, MC3, and MC6 Pro.

For a test I booted from a Linux Mint 21.3 Live USB, installed Chrome and could not get a connection. However Mint’s default Firefox did work.
Again this was a Live USB and not an install so no updates were done.
I think the stock Linux Mint 21.3 kernel version is 5.15 whereas I’m currently running 6.8.0 with Gentoo (although that was just upgraded yesterday, the previous 6.7.x series was working fine).

Thanks for the help. I have the same chrome version 122.0.6261.111
but running kernel 6.5 (6.8 is not yet available on my distro). I will check
again with the next linux upgrade…

Kinda strange it worked for you with firefox, because this browser is not compatible with the morningstar editor. I will try a virtual machine.