[Resolved] Dual Switch Lock seems to be stuck on

Hi. I just received my MC8 and am very excited about it but noticed something strange. The pedal was working normally but then the dual functions stopped working. Meaning I cannot hit B+C to toggle pages or C+D to bank up or other functions. I already checked the settings in the Editor and Dual Switch is turned off. Several times I tried changing the Controller settings. I saved these and closed and it. And I changed to the Default controller settings and that still doesn’t work. Any clue what the issue could be?

It is difficult to use the device without being able to Page toggle or any of these other functions.


There can be two other possibilities

  1. Switch sensitivity is set to highest setting
  2. Looper mode is engaged.
    Do let me know if the above helps

Hey! I turned off looper mode and it still wasn’t working. Then I turned off dual switch lock on the device itself instead of in the editor. That worked! I am pretty sure I had disabled it in the editor and it didn’t save for some reason. However, I was turning it on and off so it’s possible that this was a user error. In any case, it’s resolved!


1 Like

thanks for the update. I just tested and the saving seems fine - maybe just some issue in that instance when you saved. Anyway, glad it is resolved!

Hi James! How are you? I just sent a message on the group thread but thought I would send your way as well if you have an idea what might be the issue. I want to use the MC8 to send basic CC messages to my Elektron digitakt. I had this set up properly about a year ago and when i tried using the MC8 the Digitakt was no longer receiving the messages. I’m really not sure what this could be. I monitored the messages coming out of the MC8 and those seem to be sending properly.

Thanks in advance