Preset Select issue in Editor (PC)

Just switched from using the Desktop Editor on a Mac to using it on an offline PC, and for some reason I can no longer use the Select Preset drop down menu in the top right corner. I can, however, still use the other functions on the top row, and so far everything else functions perfectly. I’ve tried reinstalling the application, as well.

Not sure what’s happening, but is there another way to access those extra presets on an MC8 through the editor? Thanks for the help!

I was able to program my MC6 to access these hidden presets (Q-V) on the MC8, and sure enough it popped up on the editor! So that’s great, I can now program them!

May still want to look in and see if there might be a bug or something.

P.S. MC8 + MC6 + ML5 = the only way to fly!

I think the issue was caused when you switched devices. You’ll need to refresh the editor to load the new settings for the new device. Thanks for the feedback!

Unfortunately the Select Preset drop down doesn’t work on either the MC6 or the MC8 on the PC. I’ve tried restarting the program and computer.