One short press sends 2 identical cc messages - MC6 MK2

I just received a new MC6 MK2. When I program any button to PRESS and assign a cc number, value and channel, and making sure it’s set to position 1, a short press will send 2 identical messages. If I hold the button down for about 3 seconds, it’ll send only one message. I’m on 1.07 firmware. Anyone come across this before? Thanks

It might be a situation where you have an unintentional loop…
Where you have the command going out of the Midi Out of the MC6, through some other effects and the last effect in that chain is going back to the Midi In of the MC6. If you have Midi Thru enabled in the settings that command could be getting sent through again. It’ll usually cause a noticeably glitch where the command never stops.
Try disabling Midi Thru by hitting buttons A + F at the same time if that’s the case.

I just tried that with no change. I just have the mc6 connected USB to a laptop to control midi in gig performer 3 software. Thanks for the reply.

Is there only one command in the preset, or do you have other commands also?

It sounds like there is a PRESS command, and RELEASE command being sent together (PRESS sending on the initial hit of the switch, and RELEASE sending when your foot comes off). Are you able to upload a screenshot of your preset for us to look over?

I found that using RELEASE instead of PRESS did the trick. Thanks for your reply.

I was just typing up this topic and saw this post in the sidebar. This is absolutely infuriating me. Did you ever figure it out beyond just changing the action? Thing is, I had this preset working perfectly with PRESS on channel 1 but I had to change it to channel 9 and every preset suddenly started doing this. It sends the exact message twice. PCs, CCs, simple single commands. I can’t use release, and I shouldn’t need to…it was literally just working 10 minutes ago. Even more unusual…it does exactly what I want it to do if I select “NO ACTION”. So what’s that mean? Hope someone can help solve this one. I’m absolutely puzzled.

Can you share a screenshot of your editor settings for that preset so we have more information on how you programmed it?

I actually managed to sort this one out by updating to the latest editor and noticing that midi scroll was engaged. Once I turned that off it worked as it should. I don’t understand what it’s for but turning it off fixed my problem. Now I’m going to have to open up a discussion about controlling infinity looper because I’m losing my mind trying to figure it out. Thanks!

It had the same expierence. For me it was the switches itself. I am doing a lot Looping with the IPad. A double cc message means stop instead of play.
I changed all the switches with Lehle switches. Easy thing to do and I am not into wiring etc…
Now the the Problem is gone.

1 Like

Hey,
I have to bring this topic back.

I found the same issue on my MC6 MK2. When I press a button, the controller sends 2 identical messages. No changes of the actions (press vs. release) or something else solved it.

My controller was loaded with the freshest firmware (v3.11.1). I went down to v3.10.2 but found the same behavior. So I went down to v.3.9.6 and the problem is solved.

So something between v.3.9.6 and the newer firmwares happened.

Thanks for the support and the great devices.

Greetings
Stefan

It might be related to the virtual MIDI ports feature, where the MC6 is sending on multiple virtual MIDI ports (there are 4 virtual ports). In the Controller Settings, change this to 1:
image

Hi James,
perfect! That solved the “problem”.

Thanks a lot.

Greets
Stefan