New MC Troubleshooting?

Hi all. Brand new MC6 arrived yesterday. Lots of weird issues so far:

It turns on and responds. Connected to my PC via USB. At first, I used the desktop MIDI Editor, which worked. Then I disconnected it one time and upon reconnectING it, the desktop editor said the device wasn’t using the latest firmware. (When I boot it up, firmware version is 3.8.3). The browser editor still works. The device initially worked in my Neural plugins and DAW, but now it just appears in the list of devices and won’t allow me to select it for input. I unplugged/plugged it back in, and then neither MIDI editor can see the device, but it started to work for a bit in the plugin, letting me use the messages I had programmed initially. So I deselected it in the plugin to test, and it won’t allow me to select it again. Closed and re-opened the browser editor and it works again. The desktop editor still does not see it at all and hasn’t after the first time. Still nothing functioning in the plugin. Whole time it has been detected by my PC, and it is responsive to button presses on the unit.

Starting to feel crazy, help please?

Can you go to, click on the Devices button, which will show the list of connected MIDI devices in your computer, and share a screenshot of that list?

The desktop editor does not see the device.

Thanks for the information.

Does the Web Editor see the device?

Yes, the web editor sees the device.

After restarting the computer, the device now works within my DAW and plugins, but both MIDI editors (online and offline) do not see the device. Once I select to “work offline” it allows me to connect the device. Once I change settings in the midi editor, even once I close and disconnect it, the device will not function on the DAW or plugin.

Can you try closing your DAW and then opening the Editor. Does it work with the DAW closed? I know of some instances where having Ableton and the Editor open would sometimes cause the controller to hang. We’re still trying to pinpoint the issue.

You should also try going into Device Manger, and then Sound, video and Game Controllers. Right click on the controller and then uninstall it. Then disconnect the controller via USB and reconnect it. The controller should be re-installed and appear back in the list.

Thanks, I’ll try those steps next. I’ve noticed that the issue is with the USB connection. If I power the device with 9V and then send midi to my audio interface, the device works well in both the DAW and plugins. When I connect it via USB it starts acting strangely