ML10X stops responding to MIDI messages

I’ve got a non-MIDI mono pedal connected to the ML10X. I’ve set up a SIMPLE preset in which I can toggle it on/off.

I’ve also set up two ADVANCED presets, one with the mono pedal and one without, which I use to toggle between in order to affectively toggle the pedal on/off.

The problem is that in BOTH CASES the ML10X eventually stops responding to MIDI messages via the MC8. The only way to correct this is to power cycle the ML10X, which makes it unusable live.

Any ideas?

Can you share the bank data dump file containing the presets the you are using to control the ML10X? Let me know which presets to look at and how to replicate the issue if possible. I’ll test this on my end tomorrow.

Also, are there any other MIDI sources coming through to the ML10X? i.e. another controller/software generating MIDI and getting sent thru to the ML10X

I have a Midi problem as well. My ML10X is connected to my computer and powered too, it is directly
midi connected to my MC6. I programmed both units with the editor and they respond perfectly individually but when I use the MC6 to send a program change to the ML10X, nothing happens. I don’t use SysEx. I have other pedals after the ML10X (midi out) that respond to the MC6 so I am sure it is not a cable problem.
I checked every possibility and parameters (midi chanels, midi through, PC number) and I found nothing wrong.
I don’t know what to do. The problem started apparently after the reset to factory that I did after the bug that avoided the ML10X to start. Until recently, I changed the ML10X presets using the editor and try today to control the ML10X with the MC6, unsuccessfully.
I try to use another midi controller to send PC to the ML10X, same result.

Just to confirm, the ML10X was working fine before a factory reset? You can go to the “test function” in the global settings directly on the controller menu. Once you enter the test function, you’ll see “Test Bypass”. If you click next, it will show “Test Loop A” and so on. Those are just to test the audio signals in the ML10X loops. Just click on next (right arrow button) until you get to “Test MIDI Read”. Then send the ML10X a midi message. If a MIDI message is received, it will be displayed on the screen that a message is received.

If it does not work, can you share with us (email) a video of this test function where you are sending a message to the ML10X and your other downstream MIDI devices are responding, but the ML10x is not indicating that a message is being received?

Hi James,
I did a new reset and now everything is OK. Thanks again for your reactivity.

1 Like

In fact I noticed that when the editor is connected first to the ML10X, I mean I switch the ML10X power on with the editor already connected and active, then It doesn’t detect any midi signal from my MC6, I tested with the test fonction in the global settings. I have to disconnect it from the computer and start it again then everything works.
It is not very practical but I do with it.

What power supply are you using to power the ML10X? I just tested - USB power won’t enable the MIDI Input to work but I was able to get the MIDI IN to work after connecting a 9v power supply without having to restart the ML10X

I used first one chanel of my pedalboard power supply but after readind your message, i changed for an Electro Harmonix power supply that I got with a pedal and it worked without restarting it. I don’t know what difference it makes. To be honest, this is a cheap one. I need to replace it soon.
The midi don’t work with USB power as you noticed too.