(Minor Bug) Firmware updater in editor - Transmission failed

The Editor menu includes a “firmware Update” function. I forgot about the existence of the standalone updater and tried updating the hex file using the one in the Editor.

It’s not a major issue, as the device was still functional, no bricking, and the standalone updater works perfectly well.

But it did cause a few minutes of confusion. It starts the transfer then will stop at a random point and fail.

Would it be better to either remove or update this page to just redirect to the Github page and standalone updater, until the integrated one is in a working condition?

Workaround - the firmware updater standalone works fine.

Thanks for the feedback. It’s a new feature we implemented (can only be implemented) on the MC6 PRO. The editor has to transfer the HEX file to controller first. Once the file is received, the controller will update. If the transfer process fails, there’s no issues because the controller isn’t updating itself during the transfer.

I have not experienced any transfer issues though, will look into it further.

Using the firmware updater software is the best, and fastest. The Firmware Update feature on the editor is more for users who prefer not to download a separate software.

1 Like

It was on the MC6 pro. I’ll try it again next update.

Yup, that option will only appear for the MC6 PRO. Were you using Windows or macOS? We’ve not been able to get this to fail so it’s hard to try to replicate any issues. We work mostly on macOS and iOS but I’ll try doing more tests on Windows again.

1 Like

The firmware update in the beta editor did not work for me on Windows 11 using Chrome. I tried a couple times and then went back to using the firmware update software. I don’t remember the error message, but will give it a try again.

2 Likes

If you encounter an error in the beta editor, just right click the page, click on inspect to open the developer console, then select the console tab, and share a screenshot of any error messages there if possible. Thanks!

1 Like

I’m using Windows 10.

Still not working for me at the moment, using the Beta. I assume this is still a work in progress as I can’t see the firmware updater in the production version of the editor?

In the beta editor, when the error happens, can you right click on the page >> inspect, which will bring up the developer console. And then select the console tab and share with me a screenshot?

Not sure if I did this right. The first time I attempted the console was blank, I tried opening the console first then re-attempting the upload and got the info attached. “Reattach” came up as the error message was produced.

Hope this helps?

Again, this is in Chrome, on Windows 10 home.


Second image.

This popped up after clicking OK on the error window. This looks more useful? Looks like a timeout?

Thanks! I managed to replicate it on my Windows 10 machine (no issues on MacOS). I’ll need to troubleshoot further and hopefully we’ll have a fix.

Meanwhile, I guess the Firmware Updater Software is the way to go.

1 Like