MIDI clock help

Sorry, long read. I thought I’d try setting up MIDI clock. Some confusion, help appreciated folks! My aims are:

  1. for the MC to always send MIDI clock to two Source Audio pedals so they’re both getting the same clock value from the MC at all times.
  2. to be able to use an external switch to tap the tempo in regardless of what bank / preset is in use, and for that to result in both pedals receiving the same, new, tempo.
  3. use the %BP function to display the current tempo on the MC screen, and for this to update when I tap a new tempo in using the ext switch.

MC6MkII 3.9.4. Editor v1.2.4. “Load preset data into Editor using Switch Press” disabled. All devices on latest firmware.

5 pin DIN out to Source Audio Hub, which connects via three 1/8" TRRS to C4, Aftershock and Mercury. C4 and Mercury are set to receive MIDI clock (which is a “per preset” setting on SA pedals). All devices inc. MC are on unique MIDI channels. Nothing connected to MC 5 pin DIN in. Expression connected to port 2, triple footswitch (EHX Triple Foot Controller - correct/expected wiring) connected to port 1 using TRS.

Controller settings:

Omniport settings:

This preset (preset A) seems to send MIDI clock out, but with some issues…

The C4 shows 100.83 BPM in the Neuro editor and it’s “control” LED flashes at 100 BPM.
The MC6 shows “Pre_100”.
Good.

The Mercury shows 199.13 BPM in the Neuro editor and control LED flashes at “lots faster” :slight_smile:.
The MC shows “Pre_100”.
Not so good - the Mercury is getting twice the clock speed somehow?

Finally… if I tap tempo in using my fixed switch “MIDI Clock Tap Tempo” then the tempo goes haywire.
For example, I tap in a slow tempo using T, R or T+R, then…

  1. C4 goes to 334.34BPM and it’s control LED flashes lots faster.
  2. Mercury goes to 400BPM and it’s control LED flashes REALLY faster :grimacing:
  3. Preset A BPM on MC screen stays as “Pre_100” ie doesn’t seem to update with the :crazy_face: new tempo.

So not really sure what, if anything, I’m doing wrong. Seems I can’t get the same tempo on both pedals using an MC preset directly, and it gets worse when trying to tap tempo in using ext switch. Thanks!

Just to follow as I am rebuilding my RT config with functions added last months.

Just a remark, don’t you have a midi loop or a second source of time for the Mercury, it seems to be receiving 2 flows of time midi packets, When I was using Soleman (now removed) and MC6, I 've got exactly same results when they were sending Time together ?

Hi…. Yes, the most logical reason for the Mercury’s tempo is receiving a second clock… but given there’s nothing connected to midi in on the MC I can’t see how.

To be fair, I haven’t tried this with my laptop’s USB cable unplugged yet. No clock sending apps on the laptop but worth ruling out.

Regardless, I’m pretty certain that midi tap on an ext switch isn’t working as expected

Concerning the Neuro editor, it is a great tool but containing so many bugs… I have tried many times exchanging with Jess from SA about some of them and ways to improve but the communication has not been easy, often disturbed by Roger Smith who, curiously, seems to never have faith in the neuro hub and neuro editor concept. Always developping long arguments on the fact that it was a free tool and the Jess time was better used on something bringing incomes to SA, that SA has invested/wasted far more than any similar company (which has certainly be true at a time but…appears to me as a lack of vision) in this editor and that it was enough now. We can read its multiple posts on this theme on TheGearPage. It seems they decided to abandon the hub in 2020, cuting the v2 project that has been started. Sadly.
Sorry for the ‘aside’.

Regarding the MIDI clock, I just checked. It’s working fine, but its just that the display isn’t updating with the updated BPM when the MIDI clock is tapped from the aux switch. we’ll fix that in the next update.

1 Like

This week I noticed what @moley6knipe is describing also. Hadn’t had time to really test it but when I tap tempo using my Aux switch it often will jump way up in the 300s. I could get it right if I very purposefully/carefully step on the switch but it was very inconsistent. Will test more after work today but I did notice Tap behaving differently via Aux.

Thanks for the test! I wonder if it’s related to this 3.9.2 change?….

  • Fixed [2021-11-05] Looper Mode for aux switches is currently not available, but we will update the aux switches to always have minimal delay.

I know that’s for aux switches and not fixed, though!

I wasn’t totally sure so I didn’t put it in my comment but I think I noticed it before the 3.9.4 so that would make sense. I’d be surprised if I overlooked this issue for too long.

@CSurieux - I think you run / ran your SA pedals in the same MIDI channel as the Hub? I don’t and I’m betting (about to try!) that’s why the mercury is getting what seems like double clock. From the mercury manual:

Mercury ignores all MIDI messages sent to
it that are not on its assigned channel, with the exception of MIDI clock messages.

My hub is channel 2, my mercury is channel 4. I bet that’s what’s causing it. Work around will be to move mercury to same channel as hub, I guess!

Boo. That didn’t fix it. Tried the mercury and the hub on the same midi channel, same double clock speed on the mercury.

Tried midi out and midi thru modes on the hub, no change.

Tried unplugging usb lead from laptop at mc end - again no difference.

Odd!

When I was using Soleman and hubs with several SA pedals, amongst them Mercury, the Soleman RT signal was Ok… are you sure that there is not a loop in your midi ?
Actually the only SA pedal I am using clock with is Nemesis and I use a direct tap tempo SA pedal…
And when I want to generate RT for my synths I use a dedicated old SR18, due to past pbs with MC6, my intention was to try back MC8 using the new APIs… but…

Agreed… I must have a loop somehow, will investigate further…

I did some testing @james and the aux switch for tap is still throwing really high numbers. Seems to be if I don’t tap quick enough (if you hold the switch for any length of time it reads it repeatedly)

Thanks for the info. I think I know what might be the issue. Will look into it this week and do a fix.

2 Likes

You’re too good to us James

1 Like

Have fixed this in v3.9.5
https://morningstarengineering.atlassian.net/wiki/spaces/MMS/pages/917045253/Firmware+Release+Notes#Bugs-fixed-in-v3.9.5

Just doing my job :sunglasses:

2 Likes

Thanks @james - Friday night is midi night for me so will report back.

1 Like

Fixed! Tap working fine via fixed switch now… still getting double clock speed on my Mercury flanger (but not my C4) so (given that they’re both via the Hub and on seperate MIDI channels, and changing their channels makes no diff) the fault must lie (somehow) with the Mercury. Sigh. Will try and raise Mr Smith and friends on thegearpage :slight_smile:

2 Likes

Concerning Mercury, have you checked that your speed parameter is set correctly ?

Ah!!! Of course, that must be it! I read about that setting and didn’t even think about checking that…. I’ll check that, my thanks!! :+1:t2: