Midi behavior of Enzo over Omniport

1st post here-

I have successfully integrated multiple pedals via traditional midi cable but my enzo via trs to omniport (no midi box) is performing bank jumps upon presses (and this is not programmed). I have double checked all the global settings for the enzo and i’m confident my PC and CC commands are accurate. I’ve checked all the bank setting and I see nothing that would be causing this.

Two setting questions:

  1. Omniport jumpers- I’ve read of this on the forum but I’m not clear on what this means or if/ how this is adressed.
    Internal jumper settings for Meris
  2. When configuring omniport, do I set to midi standard or tip active?
    thank you in advance

Hi,
I think you DM’d me instead of posting this question in the topic area on the forum. I’m not one of the technicians at Morningstar…just a user on the forum. Maybe try and DM James at Morningstar(he’s one of the owners)

That being said…the Meris stuff uses Tip Positive MIDI TRS. Sorry, that’s all I can help you with. I hope you get it resolved. Much respect…John

Here’s James info…

Oh jeez I’m sorry! Not sure how that happened! Thank you :slight_smile:

1 Like

All good…no problem at all. I’m sure James will get you up and running . He helped me a bunch getting mine set up. Good luck…John

hi!

  1. You don’t need to adjust the internal jumpers (they were there before we introduced the MIDI Out software settings. The jumpers are linked to the MIDI OUT option.
    The other options are MIDI OUT Standard, MIDI Out Tip and MIDI Out Ring, which are software-implemented options for the different TRS MIDI settings.

  2. For Meris, you should set it to Tip active.

Do let me know if you have any further issues regarding this

thank you james. I think i just overlooked that the Mc6 and enzo were both assigned to ch 1. i gave mc6 its own channel and it seems to have resolved the issue.

I am having some other issues but before i waste your time I want to try a few more things. But i wanted to get back to you and say thanks!

Hi James,
The issue I’m having is whenever i send a program change message to channels 1 (enzo) or 2 (automatone) it makes a PC & control change on the microcosm (ch. 5) as well even though the microcosm is on a different channel. The weird thing is even if I send a CC message to bypass the microcosm on these presets, it still engages the microcosm. Messages works as they should when sending messages to ch. 5 (for example scrolling or on/ engaging presets or other cc parameters). All midi messages being sent to other pedals work correctly as well. I’m on v3.8.7; microcosm is 3rd pedal on midi chain, things appear to be in order, etc. i’m completely lost on this. do you think you could advise on this? thanks in advance

what is your midi signal chain like?

If you change the microcosm to a different channel other than 5, does this still happen?

yes. I’ve set in to channel 4 and 7 (separately) and it behaves the same.
Midi chain via pin: mk6>automatone>timeline>microcosm
Enzo via omniport

if your microcosm is responding to every incoming MIDI message, then likely its MIDI channel is in Omni. We don’t have the microcosm, but can you verify if you saved the channel on the Microcosm properly?
Besides this, you should monitor the outgoing MIDI messages on the MIDI monitor and just check that the messages are being sent as expected.

That would seem logical this but I’ve set the midi channel per this configuration sheet multiple times.

I will reach out to Hologram as well and report back.

Maybe you can put the Timeline on channel 5 as well, same as the Microcosm, and then see if the Timeline responds together with the Microcosm when you send a PC message to any other channel besides channel 5.

PSA: The Microcosm manual is completely messed up!! The listed MIDI channels and PC messages for presets are off, you have to do some fudging to get it to work. Also, whenever you go into global parameters, make sure the MIDI channel hasn’t changed back to Omni, because it does that sometimes and it sucks.