MC8 with Echosystem

I’ve tried and tried, but I can’t get the MC8 (v3.8.8) to control the Echosystem…

Using a TRS cable to the “control port” on the Echosystem, and I have the port on the MC8 set to Midi Tip Only. I’ve gone through all the steps on the Echosystem to turn on MIDI and verified the correct channel.

Program change events don’t change anything on the Echosystem. Am I missing something? The Echosystem doesn’t give you a lot of feedback. I guess the first step is…will the MC8 control this device without an Empress Midibox?

Yes, we have tested the MC8 with the Echosystem a number of times.

It will work with the Tip - Active or MIDI Out- Standard setting.

I think the main thing to check is if you have set up the Echosystem properly.

Did you configure the Control Port on the Echosystem correctly? It needs to be set to MIDI mode in the Advanced Config Menu.

“”"

Enter the Advanced Configuration Menu by holding down both the tap and bypass stompswitches, and then pressing the shift button. All the preset LEDs will blink yellow twice to confirm you’re in.

“”"

This shows the control port is in MIDI mode.

​And here I have it set to MIDI Channel 1.

Yes, it works!

It was a configuration issue with the Empress. As I said, it’s confusing to see what values you’re setting. I set the midi channel to (what I thought was) channel 3. The lights were red, which is probably either 8 or 13 or something like that. My error.

Thanks for the help, I’m all set now!

1 Like