MC8 v.3.12.1 Tap Tempo Bug

Just updated my MC8 to the latest firmware. I notice Tap Tempo no longer works like usual. Tapping a tempo of around 150 BPM makes the controller think I’m tapping around 435-700 BPM randomly. Please fix

Is the tapping down on a preset or ext aux switch?

If ext aux switch, we just published an update today to fix that.

it’s tapping on a preset switch.

I wasn’t able to replicate this problem on the MC8 (in the v3.12.2 firmware, though nothing was changed related to this). Can you try updating and let me know if the issue persists? If so, can you send a screenshot of your editor settings for that preset?

Rolling back to firmware v3.11.1 fixes the issue. Updating to firmware v3.12.2, the issue persists

Just to add the list of bugs:

  • Tap tempo not behaving correctly
  • Midi Clock is not sending, be it from a pre-set midi clock in a preset or Midi Clock through tap tempo. I have confirmed this issue with 3 pedals, the TimeLine, Synesthesia, and the Microcosm.

Rolling back to firmware v3.11.1 appears to fix all complaints.

  • Tap tempo behaves as normal
  • Midi clock functions in sending clock information, either through pre-set clock in a preset or through tap tempo functionality

I can double check again tomorrow, but did you check the new MIDI Clock port select feature in the General config settings?

Just make sure all the ports are selected, and then save your settings.

Just to confirm, is the MC8 showing 150 BPM on the LCD but your devices are showing >400 BPM?

No, MC8 shows 450 BPM. Midi devices does not receive MIDI Clock information.

Yes, all ports are selected as instructed.

After reinstalling the latest firmware and re-doing the checking (uncheck and recheck) it seems that Midi Clock is now going through to my pedals. They all respond to midi clock from MC8.

However, tap tempo still jumps around in my MC8. Tapping to a BPM of 120 still makes the MC8 think that its 440-600 BPM.

Thanks, just tested it. The issue is related to the MIDI clock menu.

I’ll attach an interim firmware here with the fix. Will wait for more bug reports before publishing another release next week.

2024-01-05_MC8_Firmware_v_3_12_2.hex (465.9 KB)

EDIT: Removed attached firmware, waiting for official release.


Thank you very much James, will be testing the new firmware later this afternoon. Gonna mess around a little bit more with the new firmware to catch anymore bugs.

Just tried the new firmware. All is well and working as usual. Thank you for the quick response and quick solution.

1 Like

Hi @james - was there a full release including the above fix? Or should I just use the above file to fix the issue as well? Thanks in advance

For the MC8, please use the updated firmware here: Release Firmware v3.12.2 · Morningstar-Engineering/MC8-MIDI-Controller · GitHub

@andrewwilliam26 I’d recommend updating your firmware as well

Okay James, noted. Will be updating ASAP. Thank you!

I’ve got this same bug in MC6 MKii >
Turning MIDI clock on results in crazy BPMs and trying tap tempo also give crazy results.

BTW using V3.12.3

I have the exact same problem with MC6MKII as well as there a new firmware update for my device that will fix the issue?

I have version 3_12_3 on my device but I still have the issue.

We’ll do an official release next week but this firmware will fix the issue - have sent it to a few users.

2024-01-16_MC6MKII_Firmware_v_3_12_3_v2.hex (438.8 KB)

1 Like

That’s great James.

Installed new firmware.
Can confirm bug appears to be fixed.

Many thanks for your prompt reponse.