MC8 seems to send multiple note messages to Ableton

Hello, first time poster here! I’ve had my MC8 for a little while now and have recently started trying to use it with Ableton Live 10. I have my MC8 set up to control the Looper plugin within the software.

I have it sending individual note commands for different settings on the Looper - this has been working correctly for the last few days. I have Note 17 controlling the Multi-function button, 18 controlling Clear, 19 controlling Reverse etc. These are all being sent on MIDI channel 7, which no other device is using.

Currently it seems to be sending multiple commands when I hit the switch corresponding to the multi-function button. After I press to record the initial loop the controller automatically sends an Undo command (I have not pressed another footswitch). It does this again while I’m in the middle of recording an overdub, cutting short the recording. If I press Redo it will start playing part of the overdub I was trying to record. Occasionally it will also send a random half or double command. Sometimes several minutes after I’ve recorded and cleared a loop, when I record a new loop it will revert halfway to a previous loop I’ve recorded and cleared. To be clear, none of this happens when I activate the looper with a mouse or a keyboard, only with the MC8.

Things were working properly for a few days, but today seem to have gone south. Here’s what I’ve tried:

Powering on and off everything several times
Changing Note values and MIDI channels
Deleting all mapping and only re-mapping the multi-function button.
Changing USB cables
Changing USB ports (switching between my hub and the port in the laptop)
Changing footswitch sensitivity
New projects in Live
Factory Reset

Thank you!

I have the same issues in Live 10!

Did you end up finding a fix?

We have documented the solution to this here

https://morningstarengineering.atlassian.net/wiki/spaces/MMS/pages/645595137/Ableton#Sending-Note-On-messages-seem-to-trigger-Ableton-functions-twice

1 Like

Hola, j’ai exactement le même probleme que tu as eu, comment as tu fais finalement, j’ai essayé avec le fichier .txt comme on t’as proposé mais ça ne marche pas.
Ca fait des heures que je cherches une solution et rien, merci de ton aide

This solution did not work for me and I’m having a similar duplicate “Note On” issue. I’ve setup the MC8 to send on Press, but it is either being sent twice or my MacBook Air is reading the message twice. Below are screen shots showing my setup and the commands being seed on the Mac using the app Midi Monitor. I’ve tried rebooting the laptop and controller and have also tried a different USB cable. Issue continues to happen.



Also, here’s the Midi Monitor from the Morningstar Editor showing the note on command being sent twice.

Found the setting causing the issue. When I disabled “Cross MIDI Thru” in Controller Settings > General Configuration that eliminated the duplicate sending.

Thanks for the update.

If cross MIDI Thru is on, the incoming USB MIDI messages will be sent out as well. Weird implementation but iirc this was implemented to allow the MC8 to be used as a relay between MIDI software.

But that means that maybe you had the MC8 set as a “MIDI Out Port” in Ableton as well. Only MIDI IN needs to be selected. More info here: Ableton

1 Like