MC8 not sending MIDI thru ML5 when toggling editor off to preview changes unless I power cycle

I used to be able to make changes with the editor and then see the impacts of those changes.

Now, MIDI works perfectly when I first power up. I connect to the editor and then disconnect from the editor and even unplug the USB cable from the MC8 and MIDI doesn’t send beyond the ML5 and the ML5 doesn’t respond to MIDI commands. If I power cycle my board it will work again.

I’d ideally like to figure out a workflow that doesn’t lock up my MIDI so I can make changes and then preview them without a power cycle.

Any advice? Any other info you need from me about my setup? This used to work fine, but doesn’t. I’m on the latest 3.6.9 and the latest editor. I remember at one point there being a setting that was added so that you could preview your MIDI easier. With this setup, even if I want to trouble shoot, when I connect to the editor to monitor the MIDI or activity, it doesn’t flow through and my setup doesn’t respond to the commands until I power cycle.

I’m not sure what might be causing this but , can you try this - if the next time you experience this, just power cycle the ML5 and see if the issue is resolved? Or power cycle the MC8, so we know where the issue might lie.

Btw, you don’t need to disconnect from the editor to test your changes. You can just go to Editor Settings and turn this setting off:

This will allow you to have full functionality of the controller when connected to the editor. You just won’t be able to select presets in the editor by pressing down on the switches, but you can still select preset via the dropdown box:

I am able to reproduce the issue 100% of the time. Here is exactly what happens:

  • connect editor to my pedal board through MC8 USB

  • make an edit to preset A (Meris Hedra MIDI controlled preset)

  • save, disconnect editor, unplug usb

  • click a home bank jump preset to change the preset on the MC8 (when I disconnect, it is on the preset A I was just editing)

  • click preset A…nothing happens to Meris Hedra but MC8 toggles

  • unplug ML5 in my chain, wait a few seconds, plug ML5 back in

  • click a home bank jump preset to change the preset on the MC8 (we were last on preset A trying to get it to work)

  • click preset A…preset A works and Meris Hedra responds as expected

My MIDI chain is…

MC8 > ML5 > MIDI Solutions Quadra Thru (split signal into 2)
path 1> Panda AUdio - Future Impact > SA Reflex Expression Pedal
path 2 > Meris

MC8 ports have AUX 3 button in slot 1, expression pedal in slot 2, particle v2 in slot 3, tensor in slot 4

Meris MIDI controls Hedra, Ottobit, and a Context (in the last slot since Red Panda won’t allow MIDI thru for a MERIS MIDI)

I also deselected the option you suggested for editor settings, but I find that once connected to the editor, I cannot get my MIDI to work at or beyond the ML5 in my chain unless I power cycle the ML5. I’m using the ML5 only with on/off commands for each send I don’t take advantage of any presets (yet).

Any and all advice is appreciated…it’s pretty painful having to power cycle the ML5 every time I make an edit with the editor. Also should be noted that I’m powering both the MC8 and the ML5 on a single node of a cioks DC7 power supply.

I’m trying to wrap my mind around how the ML5 will be affected when you save on the editor because with the Editor, all the communication is via USB and nothing is sent out the DIN5 port when you click on save in the editor.

Can you share with me your controller data dump file via our help email? I’ll load it into my controller and set up the ML5 to try to replicate the issue.

1 Like

Sure. How do I get the data dump file?

Hi… In the editor, Controller Backup and then Backup All Banks. Produces a JSON file which you can attach here or to email…

https://morningstarengineering.atlassian.net/wiki/spaces/MMS/pages/931299334/Editor+v1.2.4+Manual#Controller-Backup

1 Like

controller_settings_all.json (9.1 KB)

This is the file for the controller settings. You can download the file for your bank data here:

Just click on Current Bank

Apologies for the delay in getting back to you. I’ll work to get an update posted here tomorrow. Been down and out the past week or so and finally getting caught back up.

No worries - send it to me when you can.

Can you also try this: Turn off Cross MIDI thru in the controller settings. Does it help with the issue?

Morningstar_MC8_Bank_Backup_cosmic_20220122_145822.json (51.3 KB)
Here’s the controller setting. Problem persists exactly as written.

I will now try to turn off the Cross MIDI thru and test…

Cross MIDI thru has been off during my testing. I will try with it on.

I ran a few other tests and it seems once I connect the MC8 to the editor, it blows out the connection to the ML5 and anything down chain from the ML5. I have to power cycle the ML5 for MIDI to be received at the ML5 and beyond. This only happens when I connect to the editor. When I’m using my setup and not connected to the editor, everything works fine. I am only using the ML5 for MIDI to open/close switches…no presets via PC, only CCs.

…and I updated to 3.9.7 from 3.9.6 and the problem went away. Also, that mobile app for ipad is excellent! Loving that update!!!