MC8 not enabling / disabling presets

I’ve recently acquired a Stomp in the hope to replace a couple of 200 series boss pedals on my board, although i’m having a mulitude of issues with my MC8.
In some cases it will enable the preset but not disable, whilst sometimes it will not enable but change banks.

I have a feeling its down to my lack of midi knowledge as my Ottobit won’t engage either.

In my previous set up with DD200, SY200 + Ottobit, it worked and used it often in a live scenario with no issues. I’m not using any midi boxes. I’m using the FX loop of the Stomp for some non-midi pedals. Stomp was working fine before I hooked it up to MC8

Can you share a screenshot of the editor showing one of the presets you have programmed to control the Stomp, that is not working as you expect?

It’s worth noting the PC message is exactly the same for both Press 1 and Press 2. I could be wrong but would anticipate the two messages being different.

I’ve actually solved it as I was watching this video because I simply didn’t realise a bank in the Stomp equates to a bank in MC8, therefore I need a separate bank for each preset. I was trying to cram every preset into the same bank.