MC8 Locking Up/Freezing

My controller has frozen on me (unresponsive) several times now. At first I thought it was only happening in editor mode. But last night it happened at band practice without being plugged into my computer.

Seems to be happening when switching between banks. I use an external switch to bank up/down.

I’m on the current firmware. Last night’s lock up is giving me cause for concern with reliability in a live setting. Any help is appreciated.

when it locks up, if you remove the external switch cable connected to the omniport, does it resolve?

also, did you just update your firmware to v3.9 before this happened?

Hi. I don’t have the space to unplug the jacks on my board. I just pulled the main power and replugged to kick it back to life.

This is an older model (dark screen, rounded switch tips) that I purchased from the original owner. I did a factory reset and installed 3.9.6 when I got it. Recently updated to 3.9.7. I haven’t owned it long enough to compare behavior to any previous firmwares.

It’s on a 250mA tap, so that should be adequate. Unfortunately I also can’t seem to reproduce the problem consistently. Seems to happen at random.

Hi, same thing just happened to me tonight on my MC6. Froze 3 times. I just upgraded f.w. 3.9.7. I have to turn power off and on. Never did this before. I am toggling on a preset from pos 1 and pos 2 when it happens.

there is a bug when updating from pre v3.9 firmware to v3.9 which requires doing a data dump first, then updating the firmware and then loading it back in. This bug affects the bank presets.

Can you share with me your controller data dump file?

controller_settings_all.json (9.2 KB)
Here’s the controller file you requested.

Regarding the bug workaround you mentioned…Can you please walk me through that in a little more detail?


The file you shared is the controller settings file. The data file which contains your preset data can be downloaded from the “Controller Backup” tab. Click on All Banks to download the preset data for the entire controller.

Regarding the bug, the solution is to, before you update to v3.9, do a back up of your data (in the controller backup tab), then update to v3.9, and then load your data back into the controller. If you have already updated to v3.9, what you can do is just reload the v3.8 firmware, then do the data backup first.

Sorry. The jargon can be a bit confusing at times. Here’s the correct file.

Still not sure I’m following…You’re suggesting that I roll back to 3.8, re-export the file I just sent you, update to 3.9 again, then restore the backup I created whilst in 3.8?

Morningstar_MC8_All_Banks_Backup_20220131_195906.json (1.5 MB)

Roll back to v3.8, export the data, update to v3.9 and then reload the same file into the controller.

Don’t need to do anything yet - I can check the file first and then create a new backup file for you.

Actually the data in the file looks fine - just loaded into my MC8 to check.

May I recommend doing a factory reset, and then loading the data back into your controller and see if it helps?

Might be a bug somewhere - are you able to determine if it happens when the bank changes? or just executing presets within the bank?

Are you able to replicate this? If so, can you send me your bank data so I can test it on my end? Let me know which preset/bank as well.

Just making sure I’m following you…
Don’t do the procedure you suggested earlier? Instead, do a factory reset and simply re-upload the file I sent you?

yes that’s right. There’s nothing wrong with the file you sent. So just try a factory reset and then load the file back in

Done. Here’s hoping that’s the last of it!

Thanks James

Hope so! If it happens again, it’s definitely a software bug somewhere. if you can somehow replicate it, that would be useful.Do let me know if it happens again

Seems to be random, but I’ll try to replicate and I’ll send you the file.
Hi James. I tested this in bank 1 and bank 20 and I can replicate this problem. After pressing a few presets, it happens but it’s not always the same preset. when it freezes, it shows the preset long name and it stay until I power off and on. Here is the file. File backed up just before doing the v. 3.9 upgrade.
Morningstar_MC6_Backup_File_v3.8.7_2022.syx (161.9 KB)

… Maybe I’ll just load my backup and see what happens…

Ok, so I just read that presets with sysex have to be re-created in version 3.9. That must be my problem because most of my presets have sysex commands. I reverted back to version 3.8.7 and everything works fine.

Wasn’t completely successful on the restoration. I was able to upload the “all banks” file. But the editor won’t allow me to restore the controller settings.

When I click “Load Controller Settings from File”, nothing happens. I also tried Chrome, but no difference.

Ugh. This is turning out to be really frustrating. Since restoring the “all banks” file, I’m discovering
MANY recent adjustments have reverted to a previous state. Which is bizarre since I exported that file right when you asked for it. So it should have reflected what I currently had at the time.

Just spent the last hour re-doing the adjustments I made (as well as memory could serve). Hopefully I didn’t miss anything.

Never did figure out how to upload the controller settings, so I did my best from memory there as well.

Not at all how I was hoping this would go.

Can you let me know a preset/bank that was not correct? And a screenshot of what it was supposed to be? I can check it against the backup file you shared|

Regarding the controller settings, currently, when you load the controller settings file, it just populates the fields in the controller settings. You’ll then need to save it to the controller.

yes, SysEx messages need to be re-created. I managed to replicate the controller hanging as well, and yes it seems like its the SysEx messages that is causing it due to the new structure. After I fixed the sysex message then it worked fine.

There should have been a catch to prevent the controller from hanging with an incorrectly created sysex message - will look into it