MC8 Issues after firmware update

Hi. I’m having some issues after swapping out some midi pedals and updating the MC8 firmware and hoping to get some help troubleshooting. Half of my pedals have stopped responding to cc messages and I’ve run out of ideas.

My previous (working) setup consists of an MC8, midi out to Morningstar midi box, out to Widi Master, back in to MC8. The TRS midi outs on the MC8 were -

  1. Exp 1
  2. Aux FS
  3. Exp 2
  4. Jackson Asabi Drive

The pedals connected to the midi box -

  1. ML10X
  2. ML10X
  3. Ventris Reverb
  4. Strymon Timeline
  5. Source Audio EQ2
  6. Walrus M1 Mod
  7. CB Habit
  8. Empress Zoia

The changes I made were removing the Asabi and replacing it with a Kernom Ridge (still connected to the MC8), replacing the Zoia with a Strymon Cloudburst, putting the Zoia in the midi loop between the Widi Master and MC8. And the firmware update.
After powering it up again I found that the Ridge wasn’t responding to cc messages from the MC8, and through the midi box the reverb, Timeline, Cloudburst, and one ML10X aren’t responding. Also the Zoia is not responding.

Things I’ve tried to troubleshoot -

  1. Cables - checked with multimeter and working.
  2. Swapped timeline and M1 in the midi box, M1 still works timeline still doesn’t.
  3. Checked the messages being sent from the MC8 through the midi monitor, all still sending as before.
  4. Taken the Zoia out of the loop, so the Widi goes straight back into MC8 as before, didn’t help.
  5. Changed the midi channel of the timeline and adjusted the messages from the MC8 accordingly, didn’t help.
  6. Reverted to the previous firmware 3.10.2, even back to 3.9.7, didn’t help.

Feel like I might be missing something obvious, but I can’t think of anything else to try short of pulling everything apart, wiping all my MC8 data and starting over one pedal at a time. So any help before it comes to that would be greatly appreciated!

EDIT: Resolved

Fixed my issue, predictably just dumbass user error to blame.