MC8 + FM3 - Fractal Integration not working after firmware update

Hey guys,

I finally got around to updating the firmware on my MC8 which I use with an FM3.

After the update to 3.10.2, the Fractal integration no longer works. It freezes when trying to load the scenes and I am unable to leave the frozen screen until I unplug power. It then happens again. It worked great until the firmware update. Sometimes the screen will start to load in the scenes slowly but, they do not work. Screen shots below

How do I fix this?? I tried to reload the firmware and have the same results


Can you give this firmware a try and see if the issue still persists for you?
2022-10-25_MC8_Firmware_v_3_10_2_Fractal_Bug_Fix.hex (572.0 KB)

I will give it a try tomorrow night, I’m tied up today and tomorrow. I’ll keep you posted!

I just tried the firmware with the bug fix, and it did not appear to change anything. I am still having the issue with the scene select integration.

Does this happen only in the Scene select integration? How about the preset select integration, does that work ok?

Can you also check that MIDI Thru is turned off in the FM3?

I confirmed MIDI thru is off on the FM3.

I don’t have anything set up on the MC8 that uses the Preset integration, only the scene. I jump directly to presets and then choose scenes within them.

Tonight I will try rolling back to an old firmware and then loading the bug fix version of the most recent.

Update:

I rolled firmware back to 3.9.7 and tried with with my FM3. I was able to change presets without freezing but the scene integration does not display scene names on the MC8.

I then reinstalled 10.0.2 with the bug fix. There was no freezing, but I still do not see scene names.

Is there anyway I can do a hard reset and start fresh on the MC8 and reinstall the firmware? Power cycling doesn’t seem to change anything.

Thanks for the info.

Just to troubleshoot further, is the MC8 connected via USB to any computer when this is happening? If so, can you try disconnecting the USB and see if the issue still persists?

Also, are there any MIDI pedals inbetween the MIDI connected from the MC8 to the FM3 and back?

I normally power the MC8 via usb from a hub, but I tried to plug it in with a 9v plug and still have the same problem.

There are no other pedals in the signal chain. The FM3 and MC8 are connected to each other directly via two 5 pin midi cables.

Would the firmware on my FM3 be any issue? I have 5.03 on the FM3. Looks like FAS released a beta 2 for version6.

Is that the latest FM3 firmware? We don’t have the FM3, though we have the AxeFX3 which we can test again with tomorrow. I don’t think other FM3 users reported any issues like this though. Might be worth a try to update?

I updated to the 6.03 beta for the FM3 firmware and it did not help.

Still having the same issues. I took a video to illustrate this time. When the MC8 gets stuck and displays the wrong scenes, it is also unable to connect to the editor in my browser, also shown in video. I will email the video since the forum will not accept it.

I don’t think we received any video in our email. Have you sent it?