MC8 and Boss RC-505 issues

I just purchased and setup an MC8 to work with my Boss RC-505. I followed the instructions and was able to get things working perfectly. Play/Record, Play/Stop, Undo, clear and Play All commands were all working for all tracks. I turned everything off, then when I turned everything back on the 505 was not responding to MC8 switches. I power cycled and removed the midi cable, plugged everything back in. Everything started working again. I made a switch sensitivity adjustment on the MC8, and when it restarted - again it stopped working.

To troubleshoot, I have factory reset both the MC8 and 505 and rebuilt the configuration - nothing. I have also tried another controller (Nektar Pacer), and the 505 responds. Any thoughts? I’ve emailed support at morningstar so we’ll see.

I’m not sure if its relevant, but I’ve been using the mobile editor with a WIDI Jack to connect, then I’ll power it down and hardwire it to the 505.

Any ideas?

I unplugged everything, put the WIDI Jack in and went back into the mobile editor. I didn’t see anything out of the ordinary, but I did rename Bank 1. I saved the change and powered down, pulled the WIDI Jack and plugged the MIDI cable in - now it works - WTF! :rage:

I’m glad it is working, but no way I’m going to use this in a live gig until I figure out the issue.

If it is an intermittent issue, it is likely a MIDI cable problem.

But if not, then the MIDI cable might have been orientated wrongly when connected to the MC8. The MC8 MIDI OUT jack has 7 pins (the extra pins 6&7 are for powering the MC8 via phantom power) while a standard MIDI cable has 5 pins. So it is possible to wrongly angle and connect a 5 pin MIDI cable to the 7 pin MIDI port and we’ve had feedback that this was the issue from a few users when troubleshooting connection issues with them.