MC6II - perpetually sending Midi clock?

OK, first time poster here.

PSA: I did a cursory search on here and the Facebook group and didn’t find my exact issue so I apologize in advance if I missed it and reposted an solved issue.

I am running an MC6II to several wet effects (4) and when I use the midi clock I get a tremolo like effect to the BPM it sends. I have traced this back to the MC6II, as all wet effects can be off and it still persists, and when I unplug the MC6II the problem stops immediately.

I have MIDI clock persist off in the software. I am running v3.8.0, but this issue has been present since the last official release. running editor v1.0.13.

Please help, my walrus mako d1 has to use the MIDI clock for tap tempo and it isn’t in an easy to tap place on my board, otherwise I’d send CCs to my wet effects.

hi!

When MIDI Clock persist is turned off, the MIDI Clock will stop running when any action (like a switch press or an expression pedal move) is executed. You can validate this using a MIDI monitor that shows MIDI clock signals (www.midimonitor.com will show the BPM).

How do you have your devices connected? Is there anything connected to the MC6 MIDI IN port?

Nothing going into the MC6’s MIDI in, I have all pedals on different channels, the chain goes MC6 to Walrus Mako D1 to GFI Synesthesia to a powered MIDI box that feeds 2 GFI Specular Tempus and a Strymon Iridium.

I do keep a USB cable plugged into the MC6 that goes to an unpowered hub under my board. This way I can plug my GFI pedals and the MC6 into my computer all at once with a USB extender cable.

I just tested it with my MC6MKII on v3.8.0 (do note that beta firmwares need to be used with the beta editor https://editor-mkii-staging.morningstar.io/). Here are my settings:

When MIDI Clock persist is off, it works as intended - pressing any button will stop the MIDI Clock that is being sent from the MC6. Can you confirm that it does not turn off using a MIDI Monitor?

How can I get midi clock to not persist at all? I want to set midi clock on bank change and would like it to stop once the message has been sent without having to press a switch.

Would like to do this because of some clock noise from the persistent midi clock.

Currently, no it’s not possible. If MIDI clock persist is set to off, an action needs to be done to stop the clock. Perhaps you can set an unused action in a preset that executes nothing?

Thanks for the suggestion. The only drawback to this is that it seems like I would have to actually push a switch for the midi clock to stop. In my situation I want to switch banks and immediately start playing the next song without having to tap another another switch. Correct me if I’m wrong. I’ve posted my current solution here hoping some people have come up with better solutions: