MC6 Pro Messages to Control ML10X

I’m trying to set up my MC6 Pro to control my loops/presets on the ML10X. Neither the Morningstar messages, nor CC, are being received.

Thought it would be straight forward, and after watching the tutorial video and checking the manual and forums, I’m still stuck. Any guidance would be appreciated. Here is my set-up:

  • MC6 Pro (FW 3.12.0) connected to USB 3.0 hub to MacOS
  • ML10X (FW 1.1.2) connected to same USB 3.0 hub - Ignore MIDI; Device ID 1 - powered by 9V

No issues with sending MIDI CC/PC messages fine from the MC6 to my software and both devices connect to the editor without issue.

I setup a preset on my MC6 with the Press action using the Morningstar message type to send a Toggle Selected Loops message and select the loop I want to engage/disengage. Save and nothing. The loop I want to toggle is in the preset on the ML10X.

I also tried the traditional MIDI way, set toggle preset on and used the MIDI library to set the CC commands (127 for engage, 1 for disengage). Nothing. What am I missing?

A USB hub routes messages in two ways:

  1. From the host device (MacOS in your case) to any/all of the attached USB devices.
  2. From any/all of the attached USB devices to the host device (MacOS in your case).

It does not:

Route from any of the attached USB devices to any of the attached USB devices.

You can either:

  1. Use MacOS to route the messages
  2. Connect your USB hub to the MC6 USB host port (instead of MacOS)

I recommend #2.

Hi. It sounds like you need to connect the MC6 PRO MIDI Out to the ML10X MIDI In.

1 Like

In v3.11 firmware, the command is only being sent out via the DIN5 ports.

In the v3.12 firmware (currently in beta), we have updated it to send it out through 3.5mm, DIN5, USB device and USB Host port.

1 Like

Awesome. I’ll connect a midi cable to the MC6 then and give that a go or try the beta.

Does the ML10X receive the command on USB or does it need to pass through DIN-MIDI, too? The demo video was all about “ignore MIDI” so I figured USB can receive the message. Been trying to eliminate DIN cables wherever possible.

The good thing about using the DIN connection is that there is isolation in place (based on the MIDI spec) so there won’t be any issues with ground loops. For USB, there is potential for a ground loop, depending on your setup.

For example, in my setup, connecting my laptop and a monitor is fine; but once I connect this one specific monitor then I start getting some noise. Similar logic if connected to the USB host port on the MC6P.

1 Like

Well I tried connecting the MIDI directly using a DIN from the MC6P out to the ML10X input…still no response on the ML10X when trying to engage/bypass an individual loop.

I used both the the CC#X simple mode engage/bypass loops option (from the MIDI library with midi channels matched) and updating to the beta FW to try the Morningstar Toggle loops action (with ignore midi set).

The midi monitor in the editor shows midi being output and in the controller settings the midi channel output I’m using is set to DIN MIDI.

Did you have the loop preset in the ML10x preset already? it needs to be used in the preset in order to bypass and engage. If not there is no effect. Can you share a screenshot of the ML10X preset you are trying to control?

Yep. All my loops (except A) are in my preset. Here are the screen shots.

Is the ML10X connected directly to the MC6 or are there other MIDI devices inbetween?

Direct - MC6 DIN OUT to ML10X DIN IN

Tried two different cables also just to be sure.

@James, thank you for all your help with this. I also have an ML5, but never used the MIDI control, so I pulled that back out to try and send CC#7 to toggle the loop; nothing happening there either. Maybe there is a setting on the MC6 PRO I’m missing. I’ll try a factory reset of all my devices and see if that works.

So after a factory reset of all devices, CC commands to the ML5 all worked fine, but neither CC or Morningstar actions are toggling loops on the ML10X.

Issue resolved! I reverted the firmware back to 1.1.1 and everything works as expected - both through the morningstar messages and MIDI CC.

Some other sidenotes @james. -I was also getting a horrendous feedback loops even with no loops engaged…so I decided it was time to try the old firmware.

There isn’t much changes between v1.1.1 and v1.1.2, just some minor bug fixes unrelated to the issues you were facing. If possible, can you try updating to v1.1.2 again and see if the issue persists? That is the firmware that all the recently ML10X shipped with and we have not had any feedback on these issues.

I updated to 1.1.2 and all is fine. Thanks.