MC6 Pro firmware update stalled

I tried updating to the latest firmware through Google Chrome. It got stuck on the page that says “Firmware update started!”

I have tried the recommended steps, pushing on the internal button, which initially cause the Chrome page to refresh but nothing after that. I also tried disconnecting it, holding the button down, connecting and releasing after 5 seconds. Nothing.

How to I get it out of this state and back to something I can use?

Thanks!

If you power cycle the controller, does it not boot up?

If so, you should follow these steps: Firmware Upload Failure | Morningstar Engineering Helpdesk

Use the firmware uploader software to load the firmware in.

I’ve done everything listed at that page. No love.

Nothing I do gets it past the Firmware Update Started page.

In the firmware updater software, after uploading (and after any errors you are experiencing), there is a download logs button at the bottom. Can you share with me the file?

Download logs isn’t available. I can click on show logs and see them, but I can’t copy them.

It looks like you’re still using the editor to update the firmware.

You’ll need to use a separate software to recover from this:

Thanks for your patience. It’s all better and updated.