MC3 Malfunction / Screen Blank

Hey guys,
New midi user here, thanks for the patience.

I ran the firmware updater to ensure I had the latest firmware and then the screen on my MC3 went blank.

When I connect the MC3 to either the editor or firmware updater it reads as MC8 and not MC3, then a popup dialogue shows up saying something about the device not being connected / recognized.

This all happened as I was trying to troubleshoot why keystrokes weren’t registering on my macbook after being programmed into the device.

I’ve unplugged and re-plugged both the power and usb cable and there’s been no change. It still boots up as blank.

Any help getting the MC3 up and running again would be appreciated!

This can be resolved, more info here:

I also had this problem with the mc6. I ended up using the NO_KEYBOARD_USB_INTERFACE version of the firmware and it loaded up fine

@james Currently having this issue with my MC6 MK2…

It was all working fine on a gig Sat night, but when plugged in today for rehearsal - screen was completely blank.

After trying updating firmware - via all methods described - still no joy.

Have emailed support but open to any suggestions outside of what’s already documented.

The display currently just has the top row in blocks as per the pic at top of thread.

Have tried various usb cables. Im on a Mac M1 so am using a non powered USB hub. ( Although this has always worked in the past ) So tried doing on my windows machine / direct to computer but still no joy.

Just glad i have a few days to sort before the weekends gigs! Yikes! WELP!

Does the firmware updater detect the device? Try using the new updater software: Release Firmware Updater v1.1.3 · Morningstar-Engineering/Firmware-Uploader · GitHub

If not detected, try these steps: Firmware Upload Failure
and if that still does not work, please email us the firmware updater logs (downloadable at the bottom of the page).

If it was detected and you successfully updated the firmware but the issue still persists, can you confirm that it is the correct firmware (for the MC6 model) that you downloaded?

@james It is detected, and i am using that latest version.

I just stumbled across the site via the firmware updater… I did get a mac notification weeks ago saying something about Electron wont work on this machine now etc etc… I ignored it not realising it had anything to do with the MC6… I’m currently on Monetary 12.3… Could that be an issue? Something i should do in that regard?


Have just emailed email log from Windows machine. Will also email Mac logs.

And i 100% downloaded the MC6 firmware… I tried a few different versions… But no joy as yet…

Looks fine, and when you upload the firmware, the software shows that it is successful right?

If so then it isn’t an issue with the controller board. Seems like maybe the ribbon cable connecting the board and the LCD needs to be re-seated i.e. removed and put back.

Btw, we didn’t receive any email. Did you send it to

It does show as successful.

Any links to how to re seat ribbon cable before i rip it apart?

Yeah, sent about 4 emails in last few hours…

ah ok, you replied to an existing thread linked to another agent so I didn’t see it. I’ve found the thread and yes the update is fine.

To access the ribbon cable, you’ll just need to:

  1. Remove backplate
  2. Remove the omniport nuts
  3. Remove the 4 screws securing the board down.
  4. After which you’ll be able to lift the board up to access the ribbon cable. Just remove it and then fit it back again.

Oh wow!

That cable was completed unattached… Plugged back in and is working fine - Hallelujah!

Strange how that would have happened.

Anyways - can breathe easy again!

Thanks for the speedy replies / help.

1 Like

Great! Thanks for the update and troubleshooting this with us. Glad to know that the issue is resolved.