Losing my Mind.... MC6 MKII Midi out via TRS

Hi… I’m so sorry if this has already been asked, but I can not for the life of me figure out how to send midi data via the “expression” outs of my MC6 MkII…

I’m running the 3.8 beta, and have poured over videos and the manual… everything i’m seeing tells me it’s possible in the 3.8 update, but I can’t seem to find HOW anywhere within parameters…

I’m seeing in the global settings I can select AUX, Expression, etc… but no MIDI options.

Someone please tell me i’m blind and just overlooked a step…

Thank you in advance!

If you’ve updated to the v3.8.0 beta firmware (the latest one is dated 2021-01-20), you’ll need to use the beta editor (https://editor-mkii-staging.morningstar.io/).

The option is in the controller settings

:upside_down_face::upside_down_face::upside_down_face: so simple…

Thank you so much I don’t know why I didn’t think to look for that…

1 Like

Man ok - so I’ve been using the beta editor and I can’t get the midi setting to stick. I’ll save it and then restart and it’s back to the “aux” channel. Tried it multiple times and can’t figure out why the save feature isn’t holding after I restart…

Do I need to wipe the whole thing and reload the firmware?

sounds like your firmware isn’t the latest one. the latest v3.8.0 firmware is dated 2021-01-20. can you try uploading that?

Hey James!

Thanks for your help - Yes I confirmed that I am running the most current (2021-01-20) - i’ve reloaded it a couple times as well.

Should I hard reset the device and then load it?

Thanks!

No, a reset isn’t required. Even if you click on “Load settings”, it remains at Aux?

I can’t check this issue out now though, only tomorrow.

Meanwhile, you can also edit directly on the device as well, if you need to change the omniport settings.

Hey James,

OK - I changed it on the pedal itself in Global Settings and it seems to stick now! I think my issue here was one of my pedals - I’ve got it rolling with an Iridium, I’m just having trouble with 1 specific pedal not responding.

Thanks for your help! I think i’ve got it from here!

I am having trouble getting my Jackson Audio Golden boy to respond via Exp → Midi (ring active). Might be my TRS cable, not sure.

Jackson Audio is MIDI Standard, not ring active. I’m not sure why they are still advertising it as Ring active.

Oh no, I was going by whats written here - Golden Boy Transparent Overdrive - Joey Landreth Signature Overdrive – Jackson Audio

I changed Omniport settings to Midi-out standard, changed the midi channel on the GB to 3 but still no luck. Whats the most efficient way to debug this?

I just tested with the Golden Boy - MIDI Out - Standard definitely works. What MIDI messages are you sending? I would recommend trying a different TRS cable as well.

Simple Boost on and off to begin with.

CC #2 – BOOST ON/OFF (value of 127 = ON /value of 0 = OFF)

I don’t have another TRS cable, will see.

It now works but I am not sure why. I started sending cc messages to other channels in order and then the GB on channel 3 woke up. @james :slight_smile:

Timestamp Source Midi Type Data 1 Data 2 Channel
2021/01/28 17:27:56:575 Morningstar Engineering Control Change 2 127 3
2021/01/28 17:27:55:679 Morningstar Engineering Control Change 2 127 3
2021/01/28 17:26:57:919 Morningstar Engineering Control Change 2 127 3
2021/01/28 17:26:56:685 Morningstar Engineering Control Change 2 127 3
2021/01/28 17:26:54:843 Morningstar Engineering Control Change 2 127 3
2021/01/28 17:26:42:563 Morningstar Engineering Control Change 2 127 2
2021/01/28 17:26:41:065 Morningstar Engineering Control Change 2 127 2
2021/01/28 17:26:24:425 Morningstar Engineering Control Change 2 127 1
2021/01/28 17:26:23:621 Morningstar Engineering Control Change 2 127 1
1 Like