Loading issue with firmware 3.12 and editor 1.3.6.231221583

Hi,

On both windows and linux and on Chrome/Firefox/Brave, I can’t load the data from the MC6 Pro.
I use this app :
https://editor-mkii.morningstar.io/mcgen2

With Chrome/Brave the MC6 Pro doesn’t even appears in the list of available devices (only have a blank Manufacturer on Port-0)
With Firefox I have a long list of devices, 4 for my MC6 Pro, but when I click on Connect on the each of the 4 ones of the MC6 Pro I get this message for ever :
image


When I use the mobile app I can connect easily and read the MC6 (it works at least with Brave on my Android phone and Firefox on Linux) :
https://editor-mkii.morningstar.io/mcgen2-mobile

But I can’t :

  • change bank (choosing another bank in the menu doesn’t do anything, I can change preset though)
  • backup the data (cant’ find where !?)

This update seams very cool though, very nice polish on the UI !!!

Thanks for reporting this.

I just pushed an update to the beta editor (Morningstar MIDI Editor) and added this setting, which I think might be causing the problem for some Windows machine (not an issue for macOS):

Can you give the beta editor a go and let me know if leaving this setting turned off resolves the issue for you?

I’ve update the beta editor, and IT WORKS !!!
Thanks for this (and the amazing fastness), and well done !

Thanks for the update! I initially had the same behaviour when testing on my windows machine but after some code changes, it was working with this feature turned on.

I’ll push the updates to the live editor so users can toggle this.

1 Like

I have a similar issue on V3.12 that is still not solved.

On my PC running Windows 10, nothing worked until I selected by chance:
Midi Input = Port 0
Midi Output = Port 1
All other combinations fail to connect.

The problem is that this PC is not in my music room, and I am using
a laptop usually to control the MC8. This laptop runs google-chrome
for linux, which has worked flawlessly until now.

On the laptop, I have also the same connection problem. However,
when I manually select Port 0 for Input and Port 1 for Output, the web
interface reverts to Port 1 for both, before attempting to connect. And
this fails of course.

Any idea how to solve this issue?
Thanks in advance!

Is this using the manual connect method, or by selecting one of the existing combinations?
In Windows, Output 0 is taken up by some other software, so the first MIDI Output port always shows Output-1 (instead of Output-0).

Hope this article clarifies this: Which Port should I use to connect to the Editor? | Morningstar Engineering Helpdesk

I’m not familiar with this behaviour - is it possible to share a screen recording?

On my Windows PC, it is as you describe, and it works fine.
See Screenshot here:

On my Linux machine, there are two differences:
1/ The input/output ports are not numbered
2/ There appears in addition a Midi Through option that gets port number 0
See Screenshot here:

I already tried with Chrome and Brave, same issue.
I will try another Linux machine to see if the problem is generic.