Keystroke settings have no effect

Hello! I’m running into an issue with my new MC6 where I’m attempting to use the Keystroke type alongside a Press action to trigger a keyboard shortcut while connected to my computer via USB.

When I trigger the preset using the footswitch, I can see that the command is received by the Midi Editor Software, but it does not trigger the shortcut on my computer. I’ve triple-checked that my key combinations are correct, and confirmed that they work when entered on an actual keyboard. I’m not entirely sure how to debug the issue myself, so I wanted to reach out and see if someone could help me figure out what’s up.

Here’s my setup:

OS: macOS Big Sur 11.1
Firmware: 3.8.1
Midi Editor: 1.1.1

Can you share a screenshot of your preset settings on the editor?

Hey, sure thing. I think this may end up being a two-part issue, because I got it partially working this morning after noticing the alert that advised disconnecting the MC6 from the Midi Editor before testing it. Once I disconnected it, single keystroke commands would work, but I couldn’t get the modifiers below to work (though they do work if I input them with my computer keyboard):

Here’s a screenshot of the configuration I’m having trouble with:

If I change the settings to use a single keystroke (say k, instead of Ctrl+Alt+P), and I save/disconnect from the Midi Editor, it works.

So part of me is wondering if it may be an issue of Ctrl and Alt compatibility with a Mac — maybe they aren’t registered the same way that the Ctrl and Alt keys on a Mac keyboard are? :man_shrugging:

I think you should be using the CMD command instead of Control.

image

Unfortunately I tried that as well with no luck :upside_down_face:

Are there any logs I could access to see what’s being sent, or if any errors are thrown?

You can use this to check: https://keyboardchecker.com/

Here’s what I got for cmd alt P

Oooh, this site is great, thank you! Very interesting, when I do Cmd+Alt+P, this is what I get:

Notice the P didn’t register. Wondering if this has something to do with my computer or OS.

If I do Opt+Ctrl+P, it also doesn’t register the P in the UI, but the “Last Key Pressed” box temporarily registers a π character until I release the keys.

Weird. And if you press the keys you want on your keyboard, what does it show?

Ah, my fault — those screenshots were from my actual keyboard :man_facepalming:

When I visit that site and use the MC6 to trigger the key press, I get this:

That’s with the Right Windows (PC) or CMD (MAC) + RIGHT ALT + P setting for Msg 1

ah ok, I see the bug in the firmware with regards to the modifier keys. I will fix it in v3.8.2, probably by this weekend.

Great! Thanks so much for the help!

1 Like

Just installed 3.8.2 and it looks like none of my keystroke commands work now. No feedback in Keyboard Checker — nothing registers.

Is there anything I need to do differently after updating the firmware?

Yikes, sorry my bad. I have re-uploaded a firmware dated 2020-02-01. Please use that instead.

It’s working! Thanks so much, this is fantastic. Really appreciate the assistance and the fast work!

1 Like

Is anyone still experiencing issues with using dual modifiers? I can’t seem to use Option (Alt) + Cmd together. If I have one modifer in either slot they work, however using both modifiers + keystroke does not work. Tried with keyboard checker, however unable to utilize both modifiers at same time. Any ideas? Thanks

I think it was a bug in the earlier firmware. Can you update to the latest v3.8.4?

I’m already on the latest firmware v3.8.4

Thanks for the info. Can you share a screenshot of your preset setting in the editor? I’ll replicate on my end to check

Here is the screenshot of the editor. Basically, I’m trying to use Option (Alt) + CMD + A to insert a new track in Logic Pro. With this setting the Option (Alt) does not work, so only get CMD + A which is ‘select all’.

I have found a workaround to just program another modifier + key, but can only use one modifier.

Thanks for the info. It’s a bug that was fixed in the MC6 but was missed it out in the MC8. We’re preparing v3.8.5 with few more bug fixes and will include this as well.

2 Likes