Kernom Ridge does not accept MIDI message from Morningstar MC6

Hello,
I already used my MC6 and it worked well. Tried to add the pedal KERNOM RIDGE, but for some reason could not send a midi message (PC) to the pedal. I thought the cable was bad (5 pin to 3 pin) and changed to new cable, but still no success. The channel is set correctly. Any idea what can go wrong?

Not familiar with that pedal per say, but there is no standard for 5 pin midi to 3.5mm with cables. Best bet would be if you try going out of the Omniports on the MC6 and try the different midi types in the Morningstar settings (Tip Active, Ring Active, or standard) Then at least you’ll know what kind of cable you need to make/buy if the omniports are already spoken for.

I am having the same problem with the Kernom Ridge. Were you able to make any progress?

Yes I was. Most likely the problem is with the midi cable. you need to make sure you are using a type A MIDI cable. There are type A and type B cables. If you use a type B it will not work.

I’m using these Boss cables, and they say they’re type A. Must be user error. I’ll keep trying!

Thanks for the reply!

Is the MC6 connected directly to the device? If there other MIDI devices inbetween, can you confirm if MIDI thru is on?

The difference between Type A and B is that pins 3 and 5 are exchanged. You are probably using audio cables. I actualy cut and solder the wires as described.

The Kernom is the first pedal connected to the MC6. The last time to tried, I successfully changed the LCD name for button A. That’s progress for me… a complete beginner at MIDI.

I appreciate all the help, but I’m starting to believe the problem is with me. I’m going to try setting up the MC6 with the DL4 MKII I have second in the chain. If I can get that to work it would at least show the Kernom is passing the correct signals thru.

Just to wrap this up… in case it helps someone else.

Everything works great now! It was indeed a user error. In short, I was sending CCs instead of PCs. I would have known this if I had read the entire manual instead of just skipping to the CC chart.

For any future users:

  1. Power up the Kernom but ensure both the On/Off and Preset LEDs are off
  2. Dial the Kernom’s knobs to whatever you want the preset to be
  3. Connect the USB cable. Launch the Morningstar editor and select the Bank and Preset you want to assign to the Ridge’s current settings
  4. Select Msg 1 (or whatever you want), assign an action, and choose PC for “type.”
  5. Enter a PC number (I started at 2 because I think I read the Ridge uses 1 for the preset switch on the pedal). Make sure the channel is correct. The Ridge’s default is channel 1.
  6. Save the preset and click on disconnect.
  7. Ensuring both LEDs on the Ridge are off, press and hold the On/Off button until it starts slowly flashing.
  8. Press the switch on the MC6 you configured in the editor. The Ridge’s On/Off button with flash rapidly signaling its current settings have been saved to that preset.
  9. Profit!

Hope this helps someone else.

Thanks!

2 Likes

Hey thank you for posting this !!! Just what I was looking for. Any other lessons learned along the way since?

It was a cable issue - I ordered the correct cable and it’s working like a dream.

1 Like

Hi Ddc441

I was not that lucky. Just got MC6PRO and fop some reason it does not cooperate very well with kernom.
I tried strymon sunset, saving presets worked like a charm. With Kernom, well…I managed to do some basic stuff and to get the pedal responding to basic midi messages, on/off, but couldn’t save a preset at all. I use Kernom in midi through mode, It is not on default channel 1, but it is set in the pedal, and should be alright. I use boss 3,5mm Midi cable.

If I recall, the Boss cable is wired differently from what the Kernom requires. The cables from Morningstar work with mine.
3.5mm TRS to DIN5 Adaptor (morningstar.io)

I have been successfully using these Boss cables for more than a year. I’ve used the 1’, 2’, and 5’. Just make sure the cables you are using are Type A, and you can eliminate them as the source of your problems.

Rereading my post from Jan '23, I mistakenly typed USB cable. Obviously, that should have been MIDI cable. I hope that doesn’t confuse people.

thank you all for your inputs.
I’ve manage to finally get Kernom to respond, all by accident :). Nothing was happening until I put Kernom into “awaiting MIDI message mode” and then hit save preset in morningstar editor - then it worked. go figure.
BTW boss BCC-1-3535 and BCC-2-3535 seem to be type A cables, so no reason for them not to work.

1 Like

I’m glad that you got it working. Just a heads up, copy the settings on the bottom of the box and save them as “Bradley’s Theory”. On the Facebook Kernom group a poster named Bradley theorized that the setting pictured on the bottom of the box was the “best” one that the developers could come up with.
By the way , the Kernom Ridge is the main reason that I bought my MC 8.