Issues with Submenu Workflow

I am trying to create a sub-menu for a device controlled by my MC8. In this case the device is a Strymon Volante. I have a preset that turns the device on an off. I would like to create a configuration that allows me to go to a sub-menu for this device when I double tap. The submenu is implemented as presets on another bank. These presets allow me to select a favorite, change parameters, enter loop mode, etc. Plus it has a back button to get me back to the main menu. So far I have been somewhat successful configuring this workflow. The problem I have is that it is not keeping the state of the preset on the main menu when I return.

Example: the ‘Volante’ preset is configured with ‘toggle mode on’. A single press switches the effect on and off. I double tap, in either mode, will jump to a bank where I have my Sound on Sound controls. On that page is a back button. The back button is set to go back to the previous bank and page. When I go back, the preset is on position 1 regardless of the setting at the time I double-tapped.

How can I fix this issue?

Should it be able to do this?

Hi, in controller settings make sure “Remember Toggle States” is enabled.

If that doesn’t fix it, post back, there’s a few other things to try…

Thanks. I will try that.

Unfortunately, that did not work. Here are some additional details that could help resolve this:

This is the Activity Monitor output when I double click the delay on/off preset while in POS1:

Timestamp Type Action Bank Preset Msg # Msg State Message Type
2024/01/08 20:48:21:741 Bank Preset On Enter 3 3 Set Toggle
2024/01/08 20:48:21:741 Bank Preset On Enter 3 3 Set Toggle
2024/01/08 20:48:21:738 Bank Preset On Enter 3 2 Select Exp Message
2024/01/08 20:48:21:738 Bank Preset On Enter 3 2 Select Exp Message
2024/01/08 20:48:21:737 Bank Preset On Enter 3 1 Looper Mode
2024/01/08 20:48:21:737 Bank Preset On Enter 3 1 Looper Mode
2024/01/08 20:48:21:674 Preset Double Tap 1 H 2 Pos 1 Bank Jump
2024/01/08 20:48:21:674 Preset Double Tap 1 H 2 Pos 1 Bank Jump

The is the output when I click the Back button:

Timestamp Type Action Bank Preset Msg # Msg State Message Type
2024/01/08 20:49:12:661 Bank Preset On Exit 3 4 Looper Mode
2024/01/08 20:49:12:661 Bank Preset On Exit 3 4 Looper Mode
2024/01/08 20:49:12:643 Preset Press 3 H 1 Pos 1 Bank Jump
2024/01/08 20:49:12:639 Preset Press 3 H 1 Pos 1 Bank Jump

What is interesting is that the delay on/off preset display shows the toggle name, but the Volante is not engaged and there is no indication that a midi message was sent.

Also, why is each message appearing twice?

Hi, don’t enable ‘toggle mode’. This will be triggered by any action. Replace your ‘press’ actions with ‘release’ and add a message with ‘toggle preset’ + ‘release’ + ‘pos both’. ‘Remember toggle states’ has to be active