Isolating Expression Pedal Messages

I “thought” each bank had its own set of 16 expression pedal messages. That may be the case, but I clearly have something confused.

My expression pedal is set to Omniport 4. When in the bank I have assigned to “Deco” I assigned the below expression messages to control various switches and parameters of my Deco pedal.

I did the same for each of the other pedals for whose parameters I control with an expression pedal. For the purpose of this discussion, I also include the expression messages for my Iridium below:

The problem I’ve encountered is when I send an expression pedal command to Deco using CC# 14 to control the tone, the same CC# is also being sent to my Iridium and adjusting that pedals Bass.

That is not intentional. Initially it was particularly befuddling because the Deco is using a dedicated MIDI out port on my MC8–it is not daisy-chained with other pedals–no thru or out signal. And what is particularly confusing is that the MIDI monitor in the online editor does not register a signal going to the Iridium–Iridium, channel 3 and Deco channel 6: The following is the MIDI monitor while Deco is selected and the expression pedal is activated with CC 14 to adjust tone.

But this is the MIDI monitor when Iridium is selected:

I don’t understand why expression messages I entered in my Deco bank are activating the same CC# in the expression settings of the Iridium bank. I “thought” they acted independently. If someone could clarify that for me, I’d appreciate it.

But my PRIMARY question is how do I stop it from happening? How do I get the MC8 to distinguish the difference? If, when setting the preset expression pedal CC#14 in the Deco, do I include CC#14 with a value of 0 and channel 3 (for the Iridium)? I don’t think so, because wouldn’t that set the Iridium’s Bass (CC#14 for Iridium) to 0? What am I missing?

Bill

Confess I’ve skim read this due to gin but: each bank can have its own expression messages for sure. BUT “whatever expression messages are currently engaged” persists when you switch banks.

Try adding a bank “on exit” or “on enter” command to deselect all expression messages.

1 Like

Consider switching to Tito’s vodka. That might help. :crazy_face:

Thanks for taking the time to skim. I’ve used that bank command before, but this occurs immediately after I have turned on my board, set all pedals on bypass then the Iridium and Deco.

I asked in a separate post how I could disengage the expression pedal on exiting a page–not bank–and you helped then–but it appears there is no answer for THAT issue so I added it to the Morningstar Wish List.

But in this case, I have not touched the Iridium expression messages and somehow it is being controlled when I engage the Deco expression messages. So strange.

I think it’s time for a Titos…

thanks, Moley…

Hi, I remember there have been issues with connecting the Iridium via an omniport. Have you tried to connect it to a different port or to change the midi configuration settings of the port you are using? Also can you share a screenshot of the patch you’ve programmed to control the Deco? I’d also double check if the midi channel of the Iridium is set correctly

Thanks, GuitarWolf–

All my Iridium presets work fine. My Timeline, Blue Sky, Boomerang and Iridium share a daisy-chained omniport MIDI signal with the Iridium at the end of that chain. I could not use my MC8’s 7 pin MIDI inputs and outputs because they are dedicated to my Beat Buddy which controls my board’s MIDI clock. So I need to use an Omniport.

I can change the Omniport’s output settings if I knew what they all meant. I can’t recall how many times I tried finding out what all the “MIDI Out” configurations mean–deprecated, tip active, ring active, type B, etc., but I did invest considerable effort in phrasing search terms. The manual / Online editor guide provides zero explanatory elaboration on the topics. So I’m open to suggestions. I’ve tried different settings to see what difference they made in different scenarios, but observed no difference. So I have one set for my dedicated three-button external foot switch, one for an expression pedal, one daisy chained to the above-listed pedals and one dedicated to the Deco. Both of the last two omniports are set for Midi out standard.

Here’s the really odd part. If I activate the tone preset for my Deco–expression message #3 with CC #14, then move the pedal while watching the MIDI monitor, the ONLY activity the MIDI monitor reports is for Data 14 on channel 6. That’s the correct CC for tone on Deco’s midi channel.

If I disconnect the dedicated MIDI cable from my Deco then move the pedal again, the MIDI monitor reports Data 14 for channel 3–that’s the bass parameter for my Iridium and what causes the FAV light to come on when I adjust the “tone” on my Deco. For some reason, the system is sending the CC#14 to my Iridium while sending the same CC to my Deco and not reporting the Iridium message in the MIDI monitor. How does that happen?

Here is the patch I’m sending to my Deco for Tone control

Thanks for the help. This is just weird–okay, it’s ALL weird, but…

Anyway, the only thing I can think of is some kind of parallel patch I need to enter with the Deco preset telling the Iridium to butt out. What’s the CC# for “Butt out?” CC#60 (Midi expression on/off) with a value of 0 (sent to the Iridium channel 3 when I activate preset expression messages on my Deco should work. I’ll try that. But it doesn’t answer the above problem… And I shouldn’t have to do it to the above problem… grrr

Okay, I just tried adding a kill command to my Iridium MIDI input when sending a tone preset to my Deco. It didn’t work. But it gets worse–I think–If I am understanding the way the expression pedal messages are handled.

I “thought” the 16 expression messages I could save in the expression pedal presets were unique to each bank. That is, whatever expression messages I enter in the expression pedal preset page for Deco should be exclusively for the Deco. But what IS happening is when I select any one of my strymon pedal banks (just the bank, not any particular, preset) while in the online editor and move the expression pedal while watching the midi monitor, it registers cc#14 for the Iridium and the Timeline and CC#15 (???) for the Big Sky. And although I had the pedals on bypass, they’re getting activated whenever I use the expression pedal. But only registering on the MIDI monitor when I have each bank selected in the online MIDI monitor.

1 Like

I just tried turning off MIDI expression messages to all pedals on entering the Deco bank. It didn’t solve the problem. I must have something screwed up in the expression pedal setting–maybe the omniport config for the expression pedal? It’s ignoring the CC bank cc messages and the MIDI monitor only shows what is being sent when each bank is selected, not all banks at once, even though they are all active. strange

Your programming is fine, as far as I can tell. But I have set up my expression msg differently.
Try to put your patches in ‘toggle mode’ . Programm a ‘select expression’ on ‘press’ in ‘pos 1’ and check the box for the expression message you want to be sent. Programm a second msg on ‘press’ with a ‘select expression’ in ‘pos 2’ and deselect all the boxes. Now you can toggle between sending an expression message and sending nothing.
Disengage the patch manually before leaving the bank.

Also the Big Sky has a bi- directional port for trs midi. According to another thread it recieves midi on tip and sends midi on ring.

Try to set the midi config of your omnipot to ‘tip’

Other than that, I’m out of ideas. At this point I’d leave your question to @james

I love when I have a good night’s rest and wake with an ingenious idea–even if it isn’t mine. :smile:

So, I tried both suggestions. Your first solved an issue I tried to resolve in a separate post: How do I get the expression pedal to stop “expressing” when I leave a preset. I had to resort to Bank presets. But your suggestion to add an expression toggle message with no expression box selected solved that problem, albeit with an additional step. But that’s okay. Thanks for that.

As far as “tip active,” I first tried that for both omniports I have assigned to non-beat buddy pedals. The Deco responded, but none of the other pedals. So I restored the ports to standard.

The empty expression message idea may have solved my immediate problem. With that setting, if I put the expression pedal through its paces, then toggle, it doesn’t appear to wreak havoc on the other pedals. That seems to only occur when I am in the online editor and watching the midi monitor, now. I understand the pedal function is affected when the online editor is being used, but how else can one use the MIDI monitor? I’m sure there is an aftermarket program I can find, but problem apparently solved, for now.

A “standing on my chair applauding your contribution” thank you!

Cheers!

Bill

Ah… if you’re seeing issues with the editor connected and you want to use MIDI monitor, just set “Load Preset Data into Editor using Switch Press” to disabled in Editor settings…

And FWIW I favour a “on bank exit” to deselect all expression messages. No need for a deselect msg per preset that way.

But “deselect” works better than the bank exit messages. I’ll play with it for a while, especially if I don’t “exit” the bank. Nice to have “options.”

Okay, I’m going to need to read that a few more times before trying. I tried my “Tito’s” suggestion and… :grinning:

I’ll let you know how it goes. Thanks!

1 Like

just as additional info, you can also use the Preset On Disengage action type, so when you select another preset, the original preset “disengages” so the message will execute

2 Likes

Thanks for that info. Yes, setting a second preset with action “disengage” and type “select expression message” with no boxes checked, accomplishes the task without having to click the same switch an additional time. This is especially helpful if I move from “Tone” with an expressible value, to an on/off or toggled non-expression preset , like, on the Deco, “classic” or “cassette”–MIDI clock on/off, etc. It eliminates the additional tap and I don’t need to leave the bank to activate bank “upon exit” commands.

It also answers my other inquiry that I added to the “wish list for future updates.” Thanks

So many choices!!!

Hi! Did you solve this problem?

I bought a Morningstar to control two analog synths, a BigSky and a Strymon Zelzah. I got the exact problem as yours, that my Zelzah receives MIDI messages intended to other MIDI Channels when using the expression pedal.

Hi:

Actually, I did a little bit of everything suggested above just to cover my bases.

  1. I paired every expression pedal message “engage” action with a “disengage message.” I guess the blank message boxes tell the pedal to shut down. It works.

  1. I’ve set all banks to bypass the expression pedal upon entry. This double checks and ensures the pedal is not active when I leave the bank in which it was last activated.

  1. I have a “bypass” all switch set on my homepage to shut everything down upon powering up my board, which I can also use while using the board which has the same effect as the bank change.

Basically, it’s one redundancy on top of another–apparently double negatives don’t count in MIDI. Honestly, there might be a less cumbersome way of accomplishing this, but this is my amalgamated approach to the input I received from the above master users. For now, it works.

Oh, and I forgot to mention one. For pedals that are especially persistent, I send a bypass CC message to that pedal when activating another basically telling the pedal to butt out. It’s just another roadblock to errant MIDI messages. It may not be the tidiest way of doing this, but it works and it’s not like I’m going to be grading my MIDI penmanship.

Good luck!

Bill

1 Like

Excellent work @crash! That looks very comprehensive!

I’ve never used the disengage command and typically would use ‘press’ in positions 1 and 2. I don’t know if that might make a difference?

Actually @crash your “on disengage” action when switching presets is excellent, I’ve stolen that. If I use Exp messages in a preset currently I deselect them with a press action in position 2.

That covers things if I disengage the preset using its own switch BUT if another preset disengages the first preset the Exp messages are still selected. Which is fine if that second preset is one where I again explicitly set Exp messages… but if it’s not, and I accidentally move the expression, anything could happen!

Really good work there

1 Like

LOL!! You don’t really believe I came up with that, do you? Actually, it was none other that James the demigod of Morningstar Engineering, himself. I covered myself with yours and Guitarwolf’s suggestions too. Thanks for all that.

1 Like