HE Microcosm not liking toggle mode

Hey guys,

I am using a MC8 to control 5 midi devices on my board:

  1. HX Stomp
  2. Timeline
  3. Mercury 7
  4. Microcosm
  5. Walrus M1

I have my banks setup with preset sounds from all of those devices, and sometimes I will assign a footswitch to just the M1 in toggle mode, to switch on/off more like normal operation. However, whenever I have a preset engaged with the microcosm on and I step on the switch for the M1, it changes the preset on the microcosm - always to the ARP mode for some reason. (Which can lead to some accidental cool noises, yet not always wanted lol).

Any suggestions for fixing this issue? Thanks.

Here are the specific midi messages for these presets:

Settings look fine. Does the issue occur when you just connect the MC8 directly to the Microcosm? So you can rule out whether any other connected devices are sending messages out to the Microcosm channel.

Make sure your midi channels for each pedal are independent, maybe try changing them from the ones they’re on now even and see if that resolves it. Then test out each pedal responding independently by sending a PC message to each channel to see that it’s responding without interference. This is how I resolved with my MC8, cosm, and meris pedals. Also check the ‘midi out / midi thru’ settings of each pedal, sometimes, a pedal will chain/pass messages to other pedals their midi chain is connected to, if this feature is enabled on a pedal.