Firmware 3.10 MainStage issue

I don’t understand what happened but in updates 3.9 onwards my presets I had for mainstage became unusable, the device I had saved before appears deactivated and 4 different MC6 appeared but it doesn’t matter which one I select nor does it work!!!

I went back to version 3.8.4 and the deactivated device still appears but when I select the device port 1 MC6 it works… I do not understand why with version 3.10 or 3.9 it does not work.

In v3.10 we implemented 4 virtual USB MIDI Ports. By default, the MIDI messages are only sent on Port 1. You can set the MC6 to send on more ports with the USB Virtual MIDI Port setting in the Controller Settings >> General Configuration menu. So if you want to use Port 4, you’ll need to change the setting to 4, which then the MC6 will send MIDI on all 4 ports.

In v3.9 there is no change at all with regards to the USB MIDI implementation.

The USB ports will appear as a new USB MIDI device like in your screenshot in v3.10.

@james Ok but i reinstall the 3.8.4 and I have the same ports, 1,2,3,4, why?

Can you try disconnecting the MC6, then go to MIDI Studio (Finder >> Go >> Utilities >> Audio MIDI Setup >> Show MIDI Studio), and then remove the controller, and then connect back the MC6?

@james

I’m ready with what you mentioned.
James, could you help me understand what happened?

Why my mainstage presets as well as neural (stand alone) does not work with version 3.10 where they added the 4 ports? I made the adjustment obviously selecting port 1 in mainstage and neural but they don’t respond. I went back to version 3.9 and made the adjustment you told me so that the 4 ports no longer appear in the options. Now everything is working with 3.9. But I can’t get it to work with 3.10

By the way I am using OS Mojave and the corresponding version of mainstage for that operating system.

In v3.10, you might need to go to Controller settings >> General Configuration and just check that the USB virtual MIDI Port setting is set to 1, and then just save the settings. If it it set to 1, then MIDI messages will only be sent on Port 1. If it is set to 4, then messages are sent on Port 1, 2, 3 and 4.

In the initial firmware we released, the default setting was 0 so no USB MIDI messages are sent out unless you re-saved your General configuration settings. We updated the firmware a day later to fix this though.

image

@james I reinstalled version 3.10.1 and I checked the
Configuration that you mention and the default port 1 appears, but it still does not work correctly, it does not respond with mainstage nor with the neural stand alone, what could be wrong? I could continue using version 3.9 but I would really like to have it updated and be able to use the improvements of the latest version especially with my fractal.

If you use a MIDI Monitor to check the outgoing messages from the controller, does anything appear?

Just to confirm, if you’re using the file dated 2022-05-06, you’ll need to save the General Config settings once, if not the default size is 0 (even though it shows 1) and nothing is sent out. This was fixed in the file dated 2022-05-07. You can also try setting it to 4 and see if it resolves your issue? This will have the MC8 send MIDI out on all 4 ports.

Ok I will test my mc6 today.

I downloaded the latest version of 10.1 (2022-05-07) and everything works fine, the only thing that caught my attention is that I no longer get the option to select between the 4 ports in mainstage and neural … it only seems to me as in versions 3.9.

you might be using the editor for the v3.9 firmware. can you confirm the url of the editor you are using?