DIG Ver 2 MIDI Clock Sync Problem?

Hi All,

I may be the first person on the planet to use the new DIG version 2 with an MC8, but just in case I’m not… just thought I’d ask here before contacting Strymon.

Have you noticed a problem with the clock multiplier when sending midi clock sync to DIG?

When in midi sync mode the TIME knob is supposed to act as a clock multiplier selector. The problem is that regardless of what position the knob was saved in on a preset, or is physically set to, DIG seems to set it to the fully clockwise (1/4 time) position when it receives midi clock. I don’t think this is the intended behaviour.

Cheers,

Simon

1 Like

Right, so… Strymon was able to replicate the clock multiplier problem and confirmed there is a firmware bug.

Workaround with the MC3/6/8 is to follow up the MIDI clock message with CC##12 value 64, which sets the TIME knob to 12 o’clock for 1 x multiplier.

Simon

So I’m having a similar issue…I’m using my MC6 MKII with the new V2 DIG. When I send a tap tempo message, the light on the DIG matches the new tap tempo set on the MC6, but it completely cuts out any delay signal. Once I tap on the actual tap switch on the DIG, the delay signal comes back in. If I then tap tempo on the MC6 with repeats going, it starts into circular repeats.

I’m pretty frustrated to say the least!

Alright so I realized I needed to use the MIDI Clock feature instead of the “Remote Tap” CC message. However, this MIDI Clock/Time Knob multiplier thing is a killer. I think I’ll probably be returning the DIG if this doesn’t get resolved via Firmware very soon.

Ok, so…

After much experimenting and using DIG in anger on Sunday with MC8, the most reliable work-around I have found is to send MIDI CC12#064 which sets TIME 1 knob to 12 o’clock / clock multiplier to 1/1.

I’m sending this as an On-Enter bank message.

HOWEVER…

If the CC message is sent too soon before DIG has stabilised on clock, it doesn’t always work. If the message is the last bank entry message sent AND a delay message (this pauses MC8 message sequence) is inserted before it, it does seem to work reliably at least during testing this evening. I’m using a delay of 1260ms, the maximum available in MC8 in a single message. I suppose you could make it longer with 2 messages if required.

For the time being I’m going to keep one preset in each bank programmed to send out CC12#064 just in case something goes wrong.

Hope that helps,

Simon

Anyone happen to know if this has been resolved via firmware w/ Strymon yet?

Not to my knowledge. I’ve been in direct email communication with Strymon about it but so far they haven’t told me if they’ve fixed it.

To be honest, I’m a little surprised at the amount of time it’s taking to get a fix out for this. MIDI control is the main selling point for these upgraded pedals, and the fact that it doesn’t work properly with something as basic and essential as MIDI clock is disappointing and very inconvenient. It can’t be that much of a big deal to make the firmware change necessary to correct this bug.

In contrast, I found a bug in the MC8 firmware a few months back and had a fix for it within 48hrs!

Simon

Yeah…too bad not everyone can be like Morningstar. :slight_smile:

I emailed them and they said it’s currently in the works, so I guess that’s good…it’s a major pain in the meantime though. He also confirmed they’re working on preset manger software too, so that’ll be really helpful…whenever that comes…

Has anyone had issues with the DIG not even accepting clock to start with? I’m using the MC6 (Omniport set to Midi standard and using a TRS cable) and a Quartz V3 as my clock for my board. My other pedals are still getting clock and I’m able to get the DIG to see CC messages but it isn’t responding to clock at all. I have turned clock on the DIG setting as well (blue LED) like the manual states, but still nothing.

That’s a new one to me, haven’t seen that happen.

Even tried different cables, and different MIDI placements; like DIG plugged direct to Quartz or DIG direct on omniport, etc. CC’s working fine, just no clock. Consider me stumped.

Maybe a factory reset?

What happens if you send CC#63 with a value of 127 first?

I did a variation of cc #63 but it wasn’t first command so I might look at that again. Also picked up a strymon branded midi/EXP cable today and that hadn’t fixed it either. Let’s see about factory reset.

Hmmm… I’ve just used ‘ACME’ whatever-brand cables with no issues - MIDI is after all just a simple serial interface.
As another test option - what happens if you use MC6’s midi clock instead of Quartz?

I hope Strymon fixes this fast because it’s a huge flaw. Anyone know if El Cap V2 has the same problem?