CME Widi Jack / Morningstar Editor - 3.12 vs. 3.11 - Recent Findings

I was recently struggling to get the Morningstar Editor working with an MC8 via CME Widi Jack (TRS/DIN Connectors).

I started this whole troubleshooting process on firmware MC8 3.12 latest version, latest editor version (Mac OS or iOS) . I also upgraded the Widi Jack to latest firmware, etc. In 3.12 scenarios, in all cases, either the editor would not connect at all or if it did connect, it would load the initial bank configuration and preset but would no longer respond to commands (ie. select another bank or preset after).

In summary, after much experimentation (using two different Macs and an iPhone) and using two MC8s that I have to compare settings and different configurations, the only way I could get the Editor and the CME Widi Jack to work correctly was using firmware 3.11 and also the 3.11 Mac OS editor.

The interesting finding I wanted to share and I’m not seeing in the other posts. After rolling MC8 firmware and Mac OS editor back to 3.11 and confirmed everything was working again, I paired the Widi Jack to my iPhone and just tried the iOS editor app to connect. It did connect but exhibited the same behaviour above with just the initial loading working correctly and then stopped responding. After re-pairing the Widi Jack back to the Mac, when I switched back to the Mac OS 3.11 editor that was previously working correctly, the Mac OS 3.11 editor was no longer connecting to MC8 after multiple attempts. What was interesting, if I re-flashed the MC8 firmware to 3.11 again (even though it was already on 3.11), the Mac OS 3.11 editor was working again with the MC8 first try.

In my observations, it appears something in the 3.12 editor (or iOS editor) is putting the MC8 in a state that it will never recover from a MIDI perspective. Only a 3.11 firmware re-flash gets it out of that state.

For now, I’m sticking with 3.11 and the 3.11 Mac OS editor as it appears to be working. I am going to repeat this process with the CME Widi Master and see if it repeats the same behaviour (my assumption is that it will) If it does, I will have a good comparison between 3.11 and 3.12 to test any future updates to see if this issue gets resolved.

Thanks for the feedback.

I just tested this. Connecting to macOS via WIDI Jack is ok, but there seems to be an issue when using iOS. And yes, it seems to put the MC8 in a state where it does not communicate with the editor anymore via the DIN5 jacks unless you restart it.

I’ll check out the issue this week

**EDIT: I tried connecting to iOS again after restarting the MC8 and this time it is working without any issues. Tried multiple connects/disconnects as well. Not sure what happened earlier but I’ll see whats up.

1 Like

I’m having issues as well with the Desktop Editor 1.3.6. 1.3.6 will not install on OS X 10.12.6. Additionally, I’m no longer able to connect to my MC8 with the prior Desktop version 1.3.0.

The Morningstar Desktop Console provides the following information:

Uncaught SyntaxError: Unexpected token ‘=’
polyfills.c4a6523fbf395170.js:1 Preflight request for request with keepalive specified is currently not supported
(anonymous) @ polyfills.c4a6523fbf395170.js:1
9FD10C76B47D478ABA2CE2297DEFA6B0.js:65 ERROR RUNTIME_ERROR onFormPageView error on FormPageViewedEventHandler: TypeError: Failed to fetch
at polyfills.c4a6523fbf395170.js:1
at o. (polyfills.c4a6523fbf395170.js:1)
at Function.execute (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at Object.onPageViewed (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at Object.handle (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at Object.activate (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at Object.init (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at Object.process (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at J.run (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)
at t (9FD10C76B47D478ABA2CE2297DEFA6B0.js:65)

I’ve attempted a Factory Reset, assuming that the reset button is the only visible pushbutton on the PCB. Is my MC8 bricked, or is there another option I haven’t tried?

The previous desktop editor framework had some issues handling the latest editor updates.

You’ll need to download the updated Desktop editor version. If you’re on v3.12 then use the v3.12 desktop editor.

1 Like