Can't get iOS app to work with CME Widi

I have a CME Widi Jack that I have plugged into the 3.5 TRS MIDI jacks on the side of my MC6 Pro. I’ve had no problem connecting to the editor with the WIDI through my computer (Mac OS) bluetooth, but I can’t get any connection to work through the iOS app. I have midimittr turned on and I’m connected to the WIDI through there. When I try to connect to the iOS app, I can see a bluetooth device show up, but when I try to connect, I just get a solid purple circle that shows up and nothing happens.

Am I doing something wrong? Any idea how to get the connection to work? Note that I’ve had the same experience in the production and beta version of the iOS editor.

The WIDI jack is set to Type B by default (there is a physical switch on the WIDI jack). If connecting to the the Type A TRS jacks, you’ll need to change it to Type A

Yes, I had already changed it over to Type A. So that’s not the problem or the cause here.

Ah ok, sorry I missed the part where you said it works with your Mac but not on iOS. I can only check on this on Tuesday once we’re back in office (Monday is a bank holiday here)

@James Any other info or suggestions you can provide here? I’m trying to determine whether I should return the WIDI Jack if it’s not going to work. Thanks!

Are you using the v3.12 firmware and editor? If so, I can confirm that there is a connection issue. No issues with the v3.11 firmware. Looking into it today.

Yes, I’m using v3.12 beta and the beta editor.

We just fixed and pushed the changes to the beta editor… You can try closing the app and reopening. At the bottom, this should be the version listed:

Thanks James. I was able to connect via iOS with the new beta editor. However, when I connect, that purple circle flashes on and off for a couple of minutes (though I’m able to edit parameters if I just ignore the circle). After a couple of minutes, it stops and then the editor seems to function as normal. But when I try to save a change (before or after the purple circle goes away), I get an “error saving to cloud” message and none of the changes save to the MC6 Pro.

Also, I don’t see any way of navigating to different banks or presets in the iOS editor. Is the only way you’re able to do that on the iOS editor by navigating on the MC6 Pro itself? I tried tapping on the “BANK 1” and “PRESET A” fields in blue at the top, but that didn’t do anything, and there’s no navigation available in the Menu.

Thanks for your help!

Just tested again, I was able to connect and save presets fine. The purple circles does flash maybe 3-4 times but total duration is <6 seconds at most. It it possible to share a screen recording of the behaviour so I can troubleshoot?

Yes, the only way right now is to navigate directly on the controller itself. We’ll add those functionalities to the Bank and Preset buttons in the app to select.

Screen recording attached here. Let me know if you can’t see/access it. I had to heavily compress so it was small enough to upload here, but it should give you the idea.

Thanks for this. That definitely isn’t supposed to happen. It looks like you have 2 CME devices connected via bluetooth to your phone. Can you try disconnecting (unpower, so they don’t communicate with each other) the one not connected to the MC6P and let me know if the same issue persists? Is the WIDI Jack sitting close to you or is it a distance away from your phone?

I’m running two MC6 Pros together, so I’ve got 1 CME plugged into each (since I need to edit each one separately). But I just tried unplugging one and connecting to the remaining one and had the exact same experience–long purple circle flashing; acting like it was saving, but nothing actually saves.

And I’m sitting in a chair in front of my pedalboard with the MC6 Pro on my pedalboard. So I’d say my phone is maybe 3 feet away from the CME, or so.

Thanks for the info.

I managed to replicate this behaviour if I turned on the “Wired MIDI Thru” setting for the WIDI Jack via the CME app. Can you confirm that yours is turned off?

I didn’t even know there was a CME app or these kinds of settings, so I thought for sure this must be the issue. But sadly, I downloaded the app and checked and my settings on both of my WIDI’s are set the same as you’re showing, including with Wired MIDI Thru set to off.

@james any luck determining what’s going on here?

We’re still looking into it. As we can’t replicate it, it’s tricky to figure out what might be going on.

Also odd that it is working on your macOS but not iOS. Can you share a screenshot of your MIDI Thru settings in the MC6 PRO? Or maybe your “all banks” data dump so I’ll just load it into my controller to test.

Sure thing. Here’s a screenshot of the MIDI Thru settings (they’re the same on both of my MC6 Pros):

And here are the bank files for both devices: (240.3 KB)

For what it’s worth — I’ve never been able to load the controller into the editor on iOS when using my WiDi dongle. I have the one that plugs into the traditional midi out port, with an MC8. It shows up as a selectable port but then just spins without loading. If I plug in to usb it works fine, and I’m pretty sure it works fine on my Mac too.

Thanks for this. MIDI Thru settings looks fine and I’ve tested with the same settings. Since it works fine on your macOS then it shouldn’t be an issue,

The other variables would be either some setting on iOS, or perhaps the mobile editor.

  1. Is there another phone you can use just to troubleshoot?
  2. Try connecting to your macOS again but access the mobile editor via this URL: Morningstar MIDI Editor Its the same one as what the app is running in the backend. Are there any issues connecting?