Bug: Editor (device?) not responsive to change presets/banks when connected

With the latest firmware/editor (v1.2.4/v3.9.4), the editor became unresponsive.

Had not do much beside use the locked and unlocked preset chooser. Then I noticed bank changes (and then preset changes) were not doing anything.

The MC6 device was still present in the selection screen but when starting up it showed “-” for bank and preset name.

The following did not work:

  • Disconnected and reconnected midi on OSX side
  • Use browser based editor
  • Restart standalone editor

Power cycling mc6 fixed the issue.

I did not try power cycling widi alone

No steps to reproduce…

And now I see a slightly different issue. None of the preset names are showing.

Did not do anything in the editor other than open the menu. But the editor is responding to preset and bank changes.

Disconnecting device and reconnecting did not fix.

Changing banks fixes. (So this is a separate issue from the original post)

I’ve seen this too. Been doing a lot of jumping around banks copying and pasting banks and presets and I’ve had freeze ups and missing preset labels. Again, power cycling the controller fixes

Me too.
What is “power cycling”?

Pull the power source cable(s) and plug them back in!

Ah, OK, that only works for a moment, some time later things starts going bad again.

1 Like

@james Wonder if this is worth a rollback or is a quick fix possible? Workaround?

Somebody posted a video to facebook of what what is likely this issue. Suspect this is biting most early adopters?

We’ve not experienced this yet.

When this happens, is the MC6 still responsive i.e. you can still bank up/down on the device itself?

Can you try using the staging editor (https://editor-mkii-staging.morningstar.io/)
If you are on Chrome/Brave browser and this happens, can you right-click on the page and go to “Inspect” to open the developers tools and then go to console and see if there are any error messages and share with me a screenshot?

Were you using the WIDI jack to connect to the editor?

Yes. That actually seems to work better than the USB connection which I gave up on.

I have not been able to reproduce this on the release or staging editor. I did see the issue where the preset names are gone (but that fixed itself). It’s a different issue.

Had another crash this evening. Web app, staging editor beta, 3.9.4.

Sorry, didn’t get screenshots (will next time) but noticed when the Chrome app crashed task manager showed many instances of Chrome running (but only the one app was in the foreground). Had to End Task on each but one of them wouldn’t quit. That was as far as I got for the evening, had to power off and get chores done!

thanks for the info. If it happens again, if you can open the console and share the logs, that would help. I’m always in the editor but have not experienced this yet. But that being said, I’m using the Brave browser (supposedly faster and less resource hogging vs Chrome) so I’m not sure if that makes a different. I’ll use Chrome more often to test.

1 Like

@james - just had a crash and caught some logs.
MC6MkII 3.9.5. Beta editor 1.2.5 Chrome app. Windows.

Attached file is txt but named json so I could upload it - from F12 Console.
crash.json (5.0 KB)

At the time, I had both Bank and Preset controls popped open at either side of the screen.
Clicking banks or presets in the pop out lists does not change bank or preset.
Closing the controls and using dropdowns does not change bank or preset.
Other controls seem to function e.g. I can use Edit Preset, Edit Bank, User Library nav buttons, and can edit whatever preset i can still see on screen when it crashed, edit bank settings etc.
Forgot to try banking directly on the device, sorry!

Keeping the chrome app open and F5 refresh fixed it without needing to power cycle MC.
Hope this helps!

And another crash. This time tried preset and bank controls on the MC and they remain responsive… just the Chrome app that doesn’t allow bank or preset changes, otherwise the editor controls remain functional.

To my layman’s eye, looks like the Chrome app is still recognising clicks:
main-es2015.39c61d401707b858a623.js:1 Keydown Event {key: ‘Alt’, code: ‘AltLeft’, charCode: 0, which: 18} - this was my clicking a bank in the popped out bank list.

another_crash.json (3.1 KB)

thanks! that helps! i’ll publish a fix later today

1 Like

@james - did you push a fix to the staging editor yet? If so, I’ve just had the same crash sadly…. Do you want a dump of controller settings and bank data?

yes, the changes should be in the staging editor. Were you able to check the console logs?

Ok, your data dump + controller settings file would help. Can you send that to our email? thanks!

Hi - yeah, console logs showed the same “brand” error as before. Just emailed json to help@ address. Thanks!

Thanks for the file.
I was not able to reproduce the error in Chrome, but Ive updated staging again with a few more safeguards. If you experience it again, can you share with me the logs?

The staging editor should read Editor v1.2.5A at the bottom.

1 Like