Bug - Cannot Select Specific Preset

Can’t reproduce this bug now I’ve got it working. Sharing mainly in case someone else finds themselves with the same issue, to explain what I did to get it going.

So this bug was very strange, I was unable to select a specific bank for editing: Bank 2, Preset C in my case.

The issue occurred while using the Beta version of the editor.

All other presets were able to be selected, just not this specific one.

I was able to swap it with an empty Preset using the rearrange function at a bank level, and the problem persisted. I think this means it wasn’t related to any strange loop that I had created in the preset itself. In other words, after rearranging, Bank 2 Preset C could still not be selected, even though it was now “empty” and what had previously been located there could be selected now it was placed in a new preset slot.

I tried clearing the cache, and starting in safe mode. Neither seemed to do anything to resolve the issue.

In the end, I was able to resolve the issue by opening the device in an older version of the editor, where I could select it and make edits.

On re-opening the beta editor, it was now working. Hurrah!

Quite a strange bug though. I’m no closer to understanding why it happened!

Thanks for the report.

The next time this happens, can you open the console log (right-click on the page >> inspect >> console tab) and share a screenshot? An error might have occurred and it’ll appear in the console (in the beta editor):


1 Like

Will do. Hasn’t happened again so far, but if it happens again I’ll give this a shot.