Boss GX-100 Midi Clock Issue


When I use the Tap Tempo feature or a preset hardcoded to specific tempo (e.g. 120 bpm), my BOSS GX-100 starts to have MIDI issues. The BOSS will show the correct BPM so the MIDI clock sync is working fine.

The problem lies however with a preset I have on the BOSS where tapping certain pedals on the BOSS sends MIDI commands to the MC6 Pro and the MC6 Pro then automatically sends MIDI commands back to the Boss. If I don’t send any MIDI clock commands to the boss no issues ever arise.

However, as soon as I send a MIDI clock commands to the BOSS, the preset mentioned above stops working and I may or may not see a “MIDI Offline!” message flash briefly on the Boss screen. The commands sent from the MC6 Pro are no longer executed on the Boss, I think, because the BOSS freaks out and stops sending the MIDI commands to the MC6 Pro which then prevents the automated commands from being sent back to the Boss. Other commands that initiate from the MC6 Pro by pressing pedals still work though.

Once I reboot the Boss, everything works again until I send another MIDI clock command from the MC6 Pro.

Can this be looked into? Happy to help troubleshoot further or send debug data if needed.

Did a little more playing around with this and found another issue. Most of the time, the BOSS GX-100 will sync to the correct BPM. However, this is not always the case. If I tap really fast like 250+ BPM, the BOSS has a hard time catching up and never ends up getting to the correct BPM. It might end up only displaying 160 BPM. The same goes for if the BPM is really slow like 15 BPM, the BOSS might only display 60 BPM. Those numbers are not exact but somewhere in the ballpark of what happens. They can vary. Some where in the middle, it always syncs perfectly. I also have a Eventide H90 and that never misses a beat and always shows the correct BPM. It seems like at some point the Boss gives up and stops processing the clock. If I change the tempo again on the MC6 Pro, the Boss starts to sync again. Is there a way to force feed the clock to the Boss?

I’m also syncing the clock with the Boss via DIN5 from the MC6 Pro, fyi.

1 Like

I little more testing and it seems like below a certain threshold, like 40 BPM, and then the BOSS doubles the BPM from the MC6 Pro. e.g. if MC6 Pro is 35 BPM, then the BOSS reads 70 BPM.

On the opposite end of the spectrum, if the MC6 Pro is set to 250 BPM or somewhere about that, then the Boss cuts it in half. So if MC6 Pro is 272 then the Boss reads 136.

Sounds possible that there is a MIDI loop. Are you connecting the MC6P MIDI OUT to the Boss MIDI IN, and Boss MIDI Out back to the MC6P MIDI IN?

Hi James,

Yes you are correct about the connections. Im assuming that in and of itself is not a problem though?

is the MIDI connection from the BOSS to the MC6P required? Can you break that connection and then test if the issue you mentioned still persists?

I’d like to be able to have the Boss talk to the MC6 Pro. I mentioned that in my first post about sending commands based on pressing switches on the Boss which then triggers commands sent from MC6 Pro back to the boss. There is no way to do that directly in the Boss. That function works flawlessly unless I introduce the MIDI clock from the MC6 Pro. They seem like two completely unrelated functions so I don’t see how that is causing a “midi loop” which I’m assuming you mean an infinite program that keeps running back and forth?

what’s your full midi chain like? is it just the Boss and MC6?

This issue sounds similar to an issue some HX stomp users were facing where midi clock is being doubled, because the HX stomp is passing midi clock thru and also sending its own midi clock.

My full midi chain is:

  • in/out via the 5 pin dins between the GX-100 and MC6 Pro

  • midi out only via expression port to the Eventide H90 from MC 6 Pro

  • midi in via 3.5mm port from Boss FS-1-WL to the MC6 Pro

To be clear unplugging the FS-1-WL and the H90 do not stop the problem. The problem is clearly with the Boss GX-100. It’s also odd that the Boss tempo only gets weird outside of approximately 40 BPM - 250 BPM. Everything in between is fine.

I’ve attached a screenshot of the BOSS GX-100 and MC6 Pro midi settings and it clearly shows that MIDI clock is set to off for the BOSS and the MC6 Pro is ignoring the midi clock. So, I guess that means I need to contact Boss then since there are no other troubleshooting steps to take.

I think I figured out why the BOSS either doubles the BPM below 40 or halves it above 250 and that’s because in the master settings the BPM range is 40-250.

This does not explain though why enabling tap tempo on the MC6Pro immediately causes the BOSS to freak out and stop sending midi signals to the MC6Pro…

Did you disable Midi Through from the 5 pin in to 5 pin out in controller settings?

So, just to troubleshoot, does unplugging the MIDI Cable connecting the Boss back to the MC6P MIDI input resolve this problem?

Unplugging it obviously is a problem because then nothing works other then the midi clock to the Boss, so that won’t ultimately help. But, I tried your suggestion first unplugging the midi in to the MC6Pro then running midi clock on MC6Pro, then stopping the midi clock, then plugging the midi back into the MC6Pro. After plugging it back, the functions stop working on the boss that are supposed to trigger. They work prior to turning midi clock on the MC6Pro (after a reboot of the Boss), but then stop working, regardless of whether the midi in to the MC6Pro is plugged in or not prior to running the midi clock.

Midi through is not enabled on the 5 pin to 5 pin.

Ok so initially I thought I had to restart the BOSS in order to get everything to work reliably again, and so I was turning off the power for my entire pedalboard. I then tried something different and tried just restarting the BOSS by unplugging it, and that did not resolve the issue. It wasn’t until I restarted the MC6Pro that things started working reliably again, until of course I run the midi clock and then the issue reappears.

So it seems that the MC6Pro is having difficulty receiving midi messages AFTER using the midi clock feature.

Let me look into this early next week and get back to you… Will try sending MIDI clock, and then monitoring the incoming messages into the MC6P

Awesome. thanks James!

Unfortunately, I was not able to replicate this. I had the MC6PRO generating MIDI clock at 180BPM, and then from a MC8, I was using the waveform generator to send CC messages to the MC6P, and then passing the incoming CC messages out to the computer to view on the MIDI monitor. The messages were all being passed through correctly, which means that the MC6 is receiving the messages correctly, and the MC6 functions were still working fine i.e. banking up/down or executing presets.

Just to confirm, you are on firmware v3.11.2 right?

Thanks for checking James. Yes, I am on v3.11.2. I’m waiting to hear back from Roland as I submitted a support ticket last week. I’ll let you know what they say.